Viewport: Shading hotkey fails at times.

I guess I’m hitting some kind of combination that clears or rebinds my Z-key to something different?
It quite regularly happens that in the middle of working, my Z-key stops swapping my shading mode. It just stops doing anything.
Pressing alt-Z at that time also does nothing.

However my keybinding seems to have been changed in a way. When I go and look at my user preferences, I get a little button that allows me to ‘revert’ the binding of my Z-key. Afaik , the binding doesn’t even change when restoring…but it does actually start working again afterwards.

your cursor has to be in the 3D view window area for the z key to swap view modes, sometimes people forget that and it seems not to work, just a possibility.