Volume Scattering not working in 2.91.2

Has anyone got issues rendering volumes in blender 2.91.2?
I am using the method of adding a box around my scene and applying a principle volume to the material and lowering the density and its just a black box when I render. I also tried doing it with the octane build but still rendering in cycles and the same thing.

I tried the method of adding a scatter shader and an absorption shader and mixing them together but im still getting the same result. The box just renders black and really quickly, as if there is no scattering going on.
Just creaated a quick scene to show an example -

I appreciate any advice its driving me nuts.

So I tried 2.91.0 and the volume worked. It must be a problem with 2.91.2. If anyone could confirm this would help others.
I knew I wasnt going mad … not yet.

Volume scattering node or principled volume are supposed to be connected under “volume” and not “surface” of your material output. Maybe that’s is from where you are having your problems.

I tried it in the volume, just when i took my screenshot it captured me trying it in the surface. I was trying everything. No luck though. are you using 2.91.2?

Ha ha!!! I found the problem. I needed to turn transparent shadows on. Gues thats the same as ‘fake shadows’ in octane.

1 Like

I’m glad you found it.