walk-o-matic

I’m trying to run the walk-o-matic script and I get this error:

Walk-o-matic v0.49.7
Proxy in use:[Object “Plane”]
Traceback <most recent call last>:
File “Text”, line 78, in ?
AttributeError: Layer

Do I miss something?

W98
Blender 2.36
Python 2.24

I think the correct python would be 2.34.

I’ve installed Python 2.3.4 and the error is still the same.

what can be the problem?

you maybe using a wrong version of python(to new) should work with

blender2.33 -2.36 python 2.3.3 :slight_smile:
blender2.32 pthon 2.2.2 :slight_smile:

I have the same problem with a number of scripts like TOPIXCloth
(blender 2.32 python 2.2.2 would not work otherwise) and same with terragen importer

got me nakered why (am im a programmer :expressionless: :expressionless: )

I’ve installed Python 2.3.3 and I get another error while running the script:

File “Text”, line 269
if cpf>LF:
^
SyntaxError: invalid syntax

Perhaps the semicolon is not a proper syntax.

By the way; is it necesary to change Python version, and change the pythonpath and so on, each time you want to run a new script? A bit disapointing…

No. I think this script will only work in python 2.2 and blender does not support 2.2.

Try this version :
http://www.zoo-logique.org/3D.Blender/scripts_python/snippets/walkingontheceiling.zip

Downloaded the walking on the ceiling blend … it ran a bit at first … then:


W A L K - O - M A T I C V 0.49.7

Proxy in use: [Object “Empty.011”] in layer 2
Target scene: [Scene “1”]

Currently processing: Heel targets
C:\Program Files\Blender Foundation\Blender\blender.exe:116: DeprecationWarning:
integer argument expected, got float
¦{ ;At¤;¦¦{ tP_+__YïF¶ï
Added [Object “leftikt”] [Object “rightikt”]
Centertarget [Object “centertarget.001”]
Unknown variable.
Traceback (most recent call last):
File “walkomatic0.49.7.py”, line 286, in ?
File “walkomatic0.49.7.py”, line 268, in doIt
AttributeError: link argument type is not supported

The animation was done … and it played … so this might be of some use … no docs though.

Just so you know I’m running Blender 2.36 on an AMD 1 GHZ Athlon processor with 128 MB ram and Windows ME

You need to get the most-current version of WalkOMatic, which is 0.49.9.

Understood … this was just from the blend file referenced above.

I’ve downloaded v. 0.49.9 and it runs, does the animation, IPOs, etc.
:smiley:
Some messages of “unknown variable” but it arrived at the end.
Thanks to all.

How about a link to where you got it? :slight_smile:

Sorry guys.

Here’s the link: http://biphome.spray.se/millfield/
At the end of the third page you’ll find a link with the text: “Get the latest update here”

Or, directly http://biphome.spray.se/millfield/walkomatic0.49.9.py

Thank you kind sir :slight_smile:

Edit -> While trying to use the script in a clean blend (version 2.36) I get the following error when executing the script:

W A L K - O - M A T I C V 0.49.9

Proxy in use: [Object “Plane”]
Traceback (most recent call last):
File “walkomatic0.49.9.py”, line 88, in ?
layer = proxy[0].layer
AttributeError: layer

I guess it won’t work in 2.36 :frowning:

This script is three years old … the author doesn’t appear to be working on it anymore. Is there anybody that might want to fix/update/rewrite it?

Is this even possible? Would this offend the original author?

All interesting questions. Sure would be nice to have though.

With Blender2.36 and Python2.3.3 installed I have followed the instructions given in the file walkodoc.html at http://biphome.spray.se/millfield/walko.zip and then runned the script version 0.49.9 (not the v. 0.49.7 that’s given in the zip file) and all has gone ok.

DYeater, I got the same error message when I had a different Python version installed. Change it to 2.3.3 and try again.

I have the full 2.3.4 version of python installed. I’m not going to install an older version and go through all of that again just to run this one script. Pity, but it really isn’t worth that.

Using the Walkomatic for Blender 2.36, I’ve succeeded in creating a proxy animation walk. Does anybody know the steps and procedures (i.e. constraints) needed to get an armature/mesh combination to follow the proxy?

hi

i’m replace some words in walk-o-matic script (two versions, .7 and .9) but not work, or i not idea how to work.

please, test if work fine or not.

[FONT=verdana][SIZE=1][SIZE=1]http://h1.ripway.com/CJD/blends/ordinaryfootwalker_242a.blend :cool:[/SIZE][/SIZE][/FONT]

Hi,

I contacted the author awhile back, while he doesn’t have time to update he has agreed to release it under the GPL and anyone is free to update it.

LetterRip

thanks letterRip.

somebody try use this version

http://h1.ripway.com/CJD/blends/ordinaryfootwalker_242a.blend (is same version upper post) i will can’t work - my english stinky :frowning: sorry