Walls are see through...

My walls in the BGE are see through. My normals are facing toward the camera… and my camera clip plane is set a correct amount. Sometimes when they are messed up they are not completely transparent. It is only a couple of the objects. Not all of them. Has anyone else had this issue.


Do you have alpha enabled on them? It could be an alpha sorting issue… try disabling that.

If not, make sure that the normals are pointed the correct way by displaying them (I think that there’s a “show normals” button in either the Editbuttons or the Objectbuttons). A little blue line should point out of the center of every face… whichever side it’s pointing out is the side the normal is facing.

You can flip individual normals by going into editmode, selecting the face, and hitting W–Flip Normals.


Yeah, looks like an alpha sorting issue. On your textures, make sure the alpha is at 100%, and ztransp is off (this is vital) also, on the object in face settings, make sure all faces are set to opaque. (this should be on opaque by default, so if you haven’t changed it or the objects don’t have UV coordinates you don’t need to look at the face settings panel)

any idea when they are gonna correct this “progressive alpha” thingy ?

Because “Clip alpha” work well for totally faded faces… but won’t give you fade-in

nice room there btw mcbridecasey

I’m under the impression that proper alpha sorting is rather resource expensive, if you take a look at games like UT2004 they have the same alpha issues blender does- but the artists make it such that multiple alpha surfaces rarely overlap (you can only really see it happen in smoke trails of rockets and such)

You didn’t by chance create those see-through objects from planes, did you? I’ve noticed that if you start your object creation by extruding a plane (rather than starting with a cube or other “3d” shape) that it seems like the inside walls of the object become opaque (rather than the outside edges as would be the case with a cube).

Thisi s why when I’m making a level for the game engine I always start with an extruded plane - that way when the player is walking around on the inside of the shape they won’t be able to see through all the walls. if you place the player inside of a cube the walls will be see through unless they can get outside of the cube.

I apologize if you already knew this and it has nothing to do with your problem. Everyone else seems to be posting responses about stuff I know nothing about. I thought perhaps the solution could be much simpler since I’ve had similar problems myself until I figured out what was going on exactly.

The easy solution, if this is in fact the problem, is to unwrap the shape in edit mode, go to the texture face options, set face to “twoside” and copy to all of the faces.

mikedpw0- only use twoside if you need both sides of the object. If you only want the face to point a different direction (IE you have a cube and all the faces are facing out, and you want them to face in) select all the faces you want to change and either flip the normals (w->flip normals) or recalculate them to the direction you want (ctrl-n to face out, ctrl-shift-n to face in)
basically, normals are a bit of information that tells the face which direction its pointing, in case you didn’t know what they were. You can toggle them to be visible, if you’re wondering which way they’re pointing.

The reason it’s best to avoid twoside is for rendering speed- when a face is pointing away from the camera it’s assumed to be on the far side of an object, and thus invisible- and it’s not drawn, saving time. By turning twoside on, the face is drawn no matter which way its pointing, so even times it’s not visible render time has to be spent drawing it.

Tks for that precision Captain,

it give me a better understanding of the difficulty to solve this issue

i figured it out… it totally was the Active Face Alpha Setting… when i imported my obj from maya it turned random polys to alpha instead of opaque…