want particles to lay on top of surface, not embed half.


From the picture above, you can see that the sprinkles are half submerged into the plate. Is there a way to make it layer on top the surface? Also, the particles also appear at the bottom of the plate, can I eliminate it?

thank in advance.

the blend file.:

Attachments

d.blend (2.59 MB)


From left:

  • empty plate
  • particles limited on the surface with a vertex group limit, settings shown
  • particles on separate object surface, no vertex group and emitter render disabled
  • 1000 particles dropped on the plate with rigid body physics

Attachments

d2.blend (1.23 MB)

hi JA12,

thanks for the reply.

I wonder what did you do to generate the vertex group for the plate 2nd from the left?

Hi JA12,

After looking at the:

I realized I missed reading the post. I guess I was distracted by other thing. I guess I was overwhelm at the time because I did not understand what you guy were saying. It was way too advance for me.

I selected vertices on an area and put them in a new group with ctrl+g.

Hi JA12,

I am sorry I don’t understand what did you mean. I selected the vertices of the plate but the particles still stick out of the plate:( I selected the vertices of top of the plate with shift-G (normal), but it only selected a small subset of vertices. Were there any other setting that I did not do?

The short answer is that you need to move the origin of the particle objects. When you use an object, or group of objects, in a particle system, they are emitted from the origin – which oftentimes is in the center of the object(s) you should move it to edge of the object.

It’s not rocket surgery. Vertex group limit puts the particles on the surface within the group, since the particles were set to emit from faces. It doesn’t solve everything, a lot of other settings control the result. One problem that remains is that the particles still are halfway in because the particle orientation and object origin control where from and in which direction the particles point, and also particle system settings that control those along with the mentioned.

To solve that, easiest way is to not use a vertex group but use a separate object to emit from. That way it’s possible to offset the geometry enough to have the particles on the surface, and limit the emission area at the same time. Much easier to do than juggling between editing particles and adjusting particle system settings to get them on the surface, especially when it’s a group of objects that would need changing.

And third possible problem is that getting the particles on top of each other if you want a lot of them on the plate. That’s where rigid body physics could help.

hi Photox,

thanks for the tip, it works!

Hi JA12,

I made it work for your layer, now, the sprinkles layer flat on the plate, not half submerged. But it does not work for my own layer. the problems with my layer is that they protrude out of the plate vertically. how do you make it flat on the plate?

thank for your help.

The particle objects have unapplied rotation. Ctrl+A -> rotation to apply.

The plate has unapplied scale, and the scale is also non-uniform. Same menu to apply. The reason I didn’t use yours is because it has subdivisions applied to the mesh which makes the structure less readable, selections more difficult, and the structure wasn’t ready for subdivisions before applying which resulted to the pinch pattern on both sides.

hi JA12,<br>It’s not rocket surgery<br>

I have this post saved in a tab, and I did not refresh the page so I did not see you post at 15:29. I appreciate your help immensely. You are my only help when I posted my not so rocket science questions. What I don’t appreciate is the condescending statement.

What you were asking in that post and I already answered, vertex group assignment, isn’t difficult. Select, assign, and set it for the particle system. That’s what I referred to with the rocket surgery. Should have separated that from the rest of the post which focused on explaining more involved parts.

I do get that these aren’t easiest things to learn, which is why I replied with plenty of information instead of just the rocket surgery comment.

go to particle system panel

under physics check " size deflect "

That is all you have to do.