Weight painting issues?

I was following this tutorial: http://www.youtube.com/watch?v=S0VS0IVylzg

When i realized that my weights arent painting. I parented my mesh to my armature and it makes all the little vertex groups, but thats it. I cant select the bones when im in weight mode (after leaving them in pose mode) and any little bit of painting i do seems to disable the mesh parts from moving with any bone.

It basically just doesnt work. The video shows the bones being selectable while in weight paint mode and then shows their various weights. This doesnt work for me, i cant select the bones at all. How do you do this and also how do you erase weight painting if you make a mistake?

Your armature has to be in “Pose Mode” (i.e. it has to be highlighted in blue) then you put your mesh into weight painting mode. At that point you should be able to click on a bone in the armature to see its weight assignments.

As far as fixing problems goes you have a few options.

  1. Keep a backup of your file so you can just restore from that if you think you will mess something up.
  2. “Undo” (ctrl+z) works in weight paint mode to undo brush strokes
  3. You can always re-paint bad areas
  4. If you want to start weight painting over “from scratch”, you can un-parent the mesh + armature, remove the armature modifier from the mesh, remove all the bone vertex groups from the mesh, and then re-parent the mesh and the armature.

Ok so when i parented the mesh to the armature i got an error message: “Failed to find solution for one or more bones”.

Now when i select the bones in weight paint mode (got that much working) no colors change. So i assume now that, even though when i move some bones parts of the mesh moves, that error message is actually refering to ALL my bones. Im pretty sure i need to weight paint each bone individually since the auto weighting does nothing.

Ok, Blender was not able to automatically assign weights to your model. This most often happens because you have duplicate vertices in your mesh or you have disconnect parts in your mesh.

-To remove duplicate vertices go into edit mode on your mesh, select all the vertices, hit “w” and select “remove doubles”.
-Do you have disconnected parts in your mesh? You should connect these to your mesh or make them a separate object.

You can try that and try to re-parent the armature. If it still does not work then you might just have to do all the weight painting by hand.

So i figured out how to select the armature, put it into pose, then select the mesh and see the paints. Its very subtle and involves a specific order, but i figured that much out. I went in and just hand painted all the weights to all the bones. Then i went in and fixed my mesh. Then i re-did some of the painting. Now when i rotate the bones in pose mode, nothing happens. The bones dont even rotate but when i click them all the weight is still painted. I feel like i hit a key somewhere that undid something.

Edit: I tried attaching a screenshot, but the file uploader on this site makes no sense. Found the file -> pressed upload -> nothing happens…

Explore Scott Kimberly

There. Pic shows me with the rotation tool active but nothing happening.

Did you click this button by accident?

Hah. I guess so. Thanks so much for all your help with this. I figured something obscure was pressed. I pressed that button and now it works again. Thanks. :slight_smile: