Weight painting not working post 2.60

After we downloaded 2.60 and installed it, weight painting has ceased to work correctly.

We uninstalled it, and tried a 2.59 and now weight painting doesn’t seem to work right there either. It paints and subtracts but only very intermittently.
We were using an older character, so made a test object in a new file and the same problem occurs there.

Any ideas?
Thanks in advance.

I wonder if it may be a setting in your user preferences? Because if you installed in the same location it might try and find the default scene (user settings scene) when you go back to 2.59.

Just a thought. But I wonder if you could give more information as to what it is doing exactly.

It’s being very temperamental adding weight paint. Sometimes you’ll get a tiny bit, most of the time none. The W-Key auto weight paint works, but I need better control than that. Sometimes it will add paint to one side of a mesh but not the other.
Subtract seems to be broken in a similar way.

OK, let me see if I can get a chance here to check it out. By the way are you using the BF release or a GA build?

The first 2.6 was BF.
I’ve tried a couple since then, from GraphicAll.
Currently trying and failing with 2.6 41226

My eldest sons reply, whenever blender 2.5x / 2.6 stops behaving for us, is to revert to 2.49.
I usually play the progressive and talk about keeping up and having faith in the direction the software goes.
In the past I’ve had several versions of 2.5 working on the same OS, but this is the second time I’ve had a problem bump across versions of blender now.

Saw this thread today and finally downloaded 2.60a from blender.org and decided to test out the weight painting. I hate to tell you, but it is working fine. Quite some time ago, weight painting had some issues with mirroring weights and I didn’t notice that today with my quick test. Test file is attached.

You could try 2 things. You could try my test file and see how it works for you, or you could upload your .blend. In my test file, if you open the objects data panel, (the icon looks like a triangle) you should find the vertex groups, just delete them all ( ‘-’ button). Then select the armature, shift select the mesh, enter weight paint.

If you wanna upload your file, I’ll look at it, but first make sure you have ‘removed doubles’ and re-tried weight painting.



weightpainttest.blend (414 KB)

Randy - thanks for looking.

I have no idea what is going on. Your test file works fine. I made a simple test file of my own and that works fine. I loaded a character and that works fine.

There isn’t a word for how I feel about this right now. A mixture of elation and insanity/frustration…

I guess it’s less important than having a working blender with weight painting, but I’d still like to know what was going on. Could loading your file have reset something? Is there any steps I can take to avoid this kind of thing in the future?

I need a cup of tea. Thanks again gents. This kind of thing changes our world.

I honesty don’t know what is going on. Loading my file should not have changed anything, any settings I had made in weight painting are stored in my .blend file. When you open your file, the settings you had made would be in effect. If you create a new file (for testing purposes) the setting should return to default. Here again, once you load in your problem file, the settings from that file should be in effect again.

Dunno, maybe it’s a ghost in the machine…


Thanks Randy.
Once again. :slight_smile: