Weird 3D view (blend file inside) What did I do?

Weird 3D view (blend file inside) What did I do?

I did something wrong here. Take a look at this video…
wacko/mpg 767kB

Here’s the BLEND file… 52kB

My ISP has a crappy server. Click reload or refresh if needed, to get the file or video.

I have a huge project that this is happening to. I must have changed a global setting somewhere. It doesn’t happen to other projects that I have.

Any help is appreciated. :smiley:

No help here, sorry. I watched the video and have never seen that phenomena before. First thing that comes to mind is normals but looking at the blend they are fine.

Here on this machine with blender 2.37a and CVS the scene looks as expected with no problems. ?? You may have a local problem like video drivers or something of that nature.

One thing I notice is view clipping. It’s so distant from the camera that if I turn on perspective viewing the object is immediately clipped from view. Other than that, maybe someone with more experience can help.

Couldn’t open your blend file in ubuntu using Blender 2.36. I’ try it later in windows 2.37a.

Have you rebooted your machine lately? Is it windows? It could be something completely unrelated to blender the program.

Just to let you know… I opened the blend with no problems. It looks normal to me when moving it around. It was just zoomed in too far to see the actual object.

sorry no help but I can say that same thing happens to me some times I looked at your blend the wacko was there. I use windows xp and 2.37 if any one knows what causes this a solution would be great.

the classic z fighting issue…

so your graphics card can’t tell which faces are in front when they are close to each other, there could be several reasons for this

you are running in 16 bit color mode [which means you probably have a 16 bit depth buffer instead of 24, much less precision]

the object is distant from the camera [depth buffer is more precise closer to the camera]

some graphics cards use a 16 bit depths buffer regardless of which color mode you are at

oh, perspective mode [if I recall] has this issue less than the orthagonal one

Scale up your model. It is microscopic. Look at the grid. It’s huge compared with your object. Scaling up your object made the weirdness disappear for me. BTW, where’s your camera?

The blend file that I linked to is a “piece” of a HUGE project (Not quite as large as that MOBAS city that is currently here in the forum). I selected that particular mesh and deleted the rest, just for the upload of the BLEND file here.

You are correct, it is microscopic, but it has to be that size in order to be proportional to the rest of the project.
To enlarge it would make it “not the same” anymore.

My camera? It is on my computer. I’ll e-mail it to you. :smiley: Like I said, I was trying to make the blend file as simple as possible, but still repeat thte same weirdness. I deleted the camera, it wasn’t needed to see the problem that I was having.

:smiley: . I thought you were doing just this piece.
Perhaps you’ve hit the limit for smallness in Blender?
If you definitely have to zoom in to this level, maybe your only option is to scale up the entire thing…

Ah, but the thing is some of us can see the scene without any trouble? Not a blender problem, something else.

Maybe you got better graphics card, or more powerful processor? My old pc has definitely hit the limit here. I wonder, what is the limit on the object size in Blender, largest and smallest. Does anybody have a benchmark on this? Would be a good thing to know.
Try it on a simple cube, scale it down smaller and smaller, what is the size limit you get before it exhibits this weirdness?