Weird artifacts when rendering with HDR light

Hi, I get this problem when rendering with HDR skies (I am using Blender Gurus Pro Lighting Skies but it happens with any HDR I tried). There are strange artifacts looking like faces that are darker (see image 1). If I turn off HDR and use an emission plane it looks ok.

This seems to only happen when there are textures and UV:s.

Any idea, anyone?

HDR version

Emission plane version


This is very likely a terminator issue: can get rid of it by using larger light source or denser meshes (use subsurf).

Thanks. But it is strange that it appears only with HDR which is a large light source since the light comes from all over. Yes, I noticed it got less when I use more subsurf but man, I can’t just make super dense meshes for everything.

The funny thing is that sometimes the problem appears and sometimes not. I still have not found a pattern.

I really wish this problem was fixed in Blender! It should definitely be considered a bug, imo.

It appears only with HDRI with direct sun in it - the sun is causing this effect, not the sky. If you use cloudy HDRI the problem wont be there.
The problem with this issue is that there is no easy solution to that. Other commercial renderers (Corona) have this problem as well. I guess there is only very little hope it will be solved in a near future. It is better to learn to workaround it.

Ok, it actually seems I can get rid of it without pushing subsurf unreasonably high, so I guess it is manageable. Thanks.

Try this:

  • Make sure your viewport is set to solid shading
  • Go to the properties panel (N-key) and then find the shading tab
  • Enable backface culling
  • Look at your character’s face

If it looks like he is missing those parts in the mesh the problem is with the surface normals. Tab into edit mode, select all, then recalculate normals outside (Ctrl-N).