weird light flickering

I’ve been working on a kinda stylised mech and made a short animation of it spinning round. Upon rendering though, The light starts going strange, see the video for what I mean. It’s very small, but gives the idea.

I’m using blender 2.4, I’ve tried recalculating normals and changing set smooth/solid but still the same problem. Any help would be appreciated.

oh, and thanks to h4x for setting up the hosting!

it would help to have the blend-file here!
but i think, there are many double faces in that - seems to be a battle mech, eh? - robot thing.
this can be the result of manually mirroring an object with the mirror-modifier still active (I had this myself twice) or something else.

anyway - search for double faces.

try going into edit mode and removing doubles.
it looks like your mesh is intersecting itself.

yeeh. double faces was the problem. rookie error. Ah well, cheers!

Damn. Spoke too soon. Fixing the few double faces hasn’t solved the problem.

Could it be that the model is not one single mesh, but a seperate mesh for each section of the mech? I made the upper and lower legs, torso and feet as seperate parts so as to make it easier to seperate them as different objects when it comes to animating.

if not, any other ideas?

post the file and it’s url. I’ll download and then search for other ideas - though I cannot promise to find anything else.

here it is, thanks for helping.

Do you have the entire mesh set to smooth? perfectly flat faces look wierd with smoth turn on sometimes. Try autosmooth with 30-45 degrees.

I tried to do something on the mesh…

  1. at the hands there are some faces partial overlapping. remodelling them and correcting the normals’ orientation should be your work. :wink:
  2. on the legs I flipped and recalc’d some normals and deleted 4 faces in the inner feet.
  3. I set the whole mesh’s faces “double sided”.

on my system it renders without flickering now. you’ll find the modified blend-file here:

please try rendering the anim yourself, because my resulting file is too big.

That’s great! Thanks a lot man.