Weird Normal map result

Hi there, I get this squared result when using a normal map.
Is this a bug, or did I miss something?

Info: The scene is just two sun lamps. The head model is smooth shaded, has a single UV map.
The uv map is generated from high res version in blender, selected to active, tangent. Looks as expected.
Connecting the Normal map to Diffuse color looks as expected.

As @Stanpancakes once told me, change your image texture from ‘color’ to ‘non color data’.

And for good measure, plug the input of the input into uv. Although it takes uv by default.

Tried that, didn’t work. Same thing.
Could it be that 4096x4096 normal map is to big for cycles to handle?

I think you have baked your normal map wrong, look at it (better yet post it (better yet post the packed blend))

is there squariness to it?

But still change to non color data.

Oh I just looked at your outliner, you have 2 other heads being rendered. Take those off, could be the issue.

4096 is just fine. Look at your outliner.

You better use “Edit post” instead of double posting :slight_smile:
Anyway, here are two normal maps I tried, both giving similar results:

Those heads are in another layer, and I deleted one of them, because it’s just a duplicate. Also, the rendering is the exact same whether you make the other head unrendarable or hidden or whatnot.

Hmmmm… Checked the material preview, the normal maps look fine there, so there has to be something wrong with the model?.. I am seriously puzzled.

Ok. For some reason it started working after changing the normal space a few times, and reloading the image.
Very weird.
Thanks anyway. Take care.

Edit: guess it’s working.