Weird reflections

In the first image i have marked a spot where the rendered image (second image) has a weird isue. To fix it i added a fresnel node, which sorted it out but cretaed a new isue. Again i have marked the spot in a not rendered image (third image, the fourth image shows the isue when rendered) I was told the glass shader needs a solidify modifier to calculate correctly, further on the glass shader needed to be mixed with a transparent shader to adjust the dark material caused by solidify. This solution does work, at least to remove the weird reflections (image 5) On the other side, now i have a material i am not satisfied with. First of all i cant see through the glass can as much as i think i should be able to. I have added an image on the node stup for image 4 (image 6 The solidify mod has been applied so i cant go back, but if you have a solution before adding it please bring it on. All solutions no matter to what stage i have explained is welcomed.

The rest of the images will be uploaded in a reply.

Tell me if its not working.

In case you don’t see this yourself: None of the attachments in your second post work (“Invalid attachment specified”)…
Anyway, you might want to consider giving us access to the .blend file - that does usually make troubleshooting much easier.

You click them, it works for me…

This is how I see your post:

And this happens on clicking the attachments:

I have reuploaded the images, and linked to the blendfile on Tell me if its stil not working.

Hopefully ive sorted it out, as well as adding a link to the blend file at pasteall. Please give me some feedback.

I took the fresnel node and plugged it into the factor of the mix node, also turned the glass to 100% white and it helped along with when I rendered without the sun lamp rendered. I would look into it more but for now I am on my crappy laptop and the subdivisions are giving it a workout along with other work stuff.

Not sure why you would need the Fresnel at all - or the Transparent shader
Just connect the Glass shader directly to the Material Output and lower the Roughness.

Your main issue is that you did disable the environment only for the camera, but not for transmission rays. Therefore you can see the apartment HDR through the can, but nowhere else. Uncheck this:

Also – what you’re going to get from this is, so to speak, “more or less perfect glass,” which might well be visually confusing.

It might surprise you to learn that sometimes real-world studio photographers would “soap-up the glass,” actually using a spray-on surface coating (such as Pam® cooking spray) on the inside surface of the container, while carefully polishing the outside to achieve fingerprint-free reflections. The purpose of this treatment is to reduce light transmission through the glass without adding a color tint, and while maintaining the sharp specularity which fools the eye into deciding that the glass is clear. The glass is often separately illuminated using fiber-optic light heads just off-camera. And the shot might well be carefully set-up to minimize the effect of refraction within the glass – which is not too often what you see (these effects instead apparently “being sought-after”) in a CG rendering of the same subject.

The lighting setup is also going to make very specific use of focused, directional lights, in addition to the usual “soft-box overhead.” Therefore, you might wish to contemplate the use of Cycles and BI, in tandem, to produce the final shot.

@IkariShinji nice catch, I completely looked over that as well. @Arev here is what it does when the transparent and fresnel is unplugged and the glass shader only plugged into the material output I also set the sun lamp to environment lighting and used the hdr as the environment light.

I dont know how to use both render engines at the same time yet. But thank you for the tips anyway.

@Flyingbanana: You say you set the sun lamp to enviromental, does that mean clickong in the colourtab and select enviromental texture?

@Arev yes then you can select your environment texture that you are using, I used my own hdr but if you select the same one you are using in the scene it will help with the scene as well. You might have to adjust the brightness to your liking.

@Ikarishinji: I cannot notice any visible changes when declickong the transmission…

Ive tried to edit this post without sucess. I do see diference now…

Top: Transmission checked, bottom: Transmission unchecked.

See the apartment HDR visible through the coffee jug, but nowhere else? Looks weird.

I have a hard time understanding the problem, but here is how I would approach it. First of all, the “sun” is way too dim for a sun, and way too big, unless going for a diffused look through a curtain or something. I got the feeling it clipped the geometry although I didn’t check, I just set more normal size to it. I also turned off caustics (but now have to handle shadows differently, I just made it fully transparent). All light transport caused by glass caustics will be lost, but I didn’t account for this in the setup below.

Also, the glass itself appears to be extremely thin I wouldn’t bother using proper glass at all. This image shows the three possibilities:

  1. Normal fresnel to mix between refraction and glossy - this is the same as what a glass shader does.
  2. Layer weight/facing to mix between transparent and glossy - inaccurate fresnel but it might work, is also easier to control.
  3. Fixed fresnel to mix between transparent and glossy - IOR is inverted for the backfacing faces on the inside preventing snells window effect that could be the culprit for the problems. When using refraction, it knows how to handle it correctly. When using transparency (it has no IOR input), you have to correct for it manually.

Rendered image on the left is using the fake fixed fresnel approach (3), whereas the right preview window shows the current hookup using real glass (1). I can’t see a significant difference:

Thank you very much. Not sure what it means when a sun clipsthe geometry though…

You don’t literally render both at the same time: you render component files, then composite them.

You will also need to measure the (RGBA) values of each, at various key points in the image, so that you can then adjust all of these to be compatible with each other. Having done that, you can now combine them regardless of source.

Also you must use a file-format such as MultiLayer OpenEXR which captures raw data. This will store all of the data (that you select) which the render engine produced, exactly as it produced it. You won’t be combining “final images,” but portions thereof. Cycles’ render becomes the base, and BI outputs are selectively combined with it. (For instance, if you’d like the coffee-pot to cast a faint shadow. Or you’d like a little bit of “just the specularity” that BI perceives coming from “a reflective object,” in order to add that to the surface of the pot to help set it apart from the surroundings in ways that Cycles won’t do.

Cycles takes points and searches for things that illuminate them. BI takes light-sources and looks for things that they illuminate. These are complementary rendering strategies. Studio lighting setups contain both soft-boxes and highly-directional lights.

So you mix the renders in compositing?