Weird Super Low Texture resolution after Cell Fracture!? ?

Hi guys, i found a strange phenomena using cell fracture add on.
After cell fracture (Own vertices mode - I’ve tried also Own particle) texture on object become as you can see in attached image:

I’m using Blender 2.72
Someone can help me?

This is the material but I think the problem is elsewhere:

Thank you!

it only happens to me?

IT looks like 2 meshes in in space. Do you have both layers selected?

Any modifiers active?

I don’t know the cause yet. I think it could be the complexity of the model. It could happen with the simple monkey upscaled too. But with the monkey after rescaling (ctrl+A) no problem. It’s very strange!

I find a solution!

For those who get into this situation: click “Debug Point” and “Debug Boolean” and maybe “Interior VGr…” too.

I’m getting the exact same problem, and your fix doesn’t help at all. Did you ever figure out what is causing this problem?

I’m having the same problem, I can’t offer a solution I’m afraid but if you select a face and check out the UVs you’ll see that all the verts from that UV have been moved to the same spot, which makes the face a solid colour…

Okay I have a solution…

Last night I was playing around with my mesh(an imported .obj), trying various things - decimating down to a tiny amount of faces to eliminate the possibility that my mesh was too complex, auto sphere project UV mapping to make sure it wasn’t something weird with the original UVs, to no avail.

I then tried separating part of the mesh, a handful of polys and using the solidify modifier. Still no go.

So then I went a step further and separated just one face, and still had the same result. So it seems there’s something weird about the object itself.

How I eventually got it to work was I created a simple cube, and then joined them together with ctrl + J, selecting my mesh first and then the cube second, so that the mesh ends up being called ‘cube’ (Not sure if it matters which way round you do this.

Then I fractured, using the default settings, and found the texture on my mesh was as it should be. YEAH!

So then just delete the fractured cube and you’re good to go. :slight_smile:

Tedri Mark’s workaround is fantastic, until blender decides to actually fix the bug that’s causing this problem:

Make sure you have applied all three Scale, Location and this time important - Rotation before you do the fracture.
Hope helps…