What are these fake duplicates in the outliner?

I used auto-rig pro and didn’t like the results, so I want to undo everything it did. I’ve deleted the rig and vertex groups it created, but there’s still duplicates of every object in the outliner. However, Blender treats these duplicates as being the same thing as the originals, so if I delete one it also deletes the other. Also, moving them into the collection that holds the originals does nothing. What caused this and how do I undo it?

I believe that you are seeing your outliner in the scenes mode and not in the layer view mode.

In the scenes mode you can see this “duplicate” but its only the way the outliner presents the scene in this mode. They are not duplicates they are the representation of the objects you have in your scene in the OBJECTS category.

Change to layer view mode and everything will be ok. But i can be wrong since you did not post any screenshot to have a clue.

Change it here: image

I get this when I have one object parented to another, but they’re not in the same collection.

The ghost is telling you that that object is a child of the one above it in the hierarchy, but it’s associated with a different collection.

3 Likes

I’ve updated my post with a picture. As you can see I’m in the view layer and yet two things are selected at the same time.

I’ve updated my post with a picture. As you can see, nothing has any parents, but yet two things are selected at the same time.

It’s simply the same object in two different collections. You can remove an object from a collection by right-clicking and selecting unlink (or by deleting the collection)

These couldn’t be duplicates because they had the same name. Blender uses a global namespace which means there cannot be conflicting names, even in different object hierarchies or in different collections.

2 Likes

Thanks. I tried unlink earlier, but it would delete the object from both collections. However, I tried unlink again on the object in the other collection and it suddenly worked properly. Very frustrating. I assume it has something to do with how the collections are nested and where the objects are in that hierarchy.

You’re welcome. I don’t know what could cause this issue, I tried replicating the hierarchy from your capture and it worked fine. That being said it’s an area (outliner and context menus) that’s been changing a lot since a couple Blender versions, and is bound to keep changing…

Could it be caused by importing a model from another program which has a different way to manage hierarchy?

I don’t see how an object would influence Blender’s behaviour when imported, but I could be mistaken

I don’t know, maybe if the origin program works with an object as being part of two collections or is it’s way of managing relations at some level, because, if you see there is a collection called “body”, that as I see includes all the meshes of the character, and there is this other “clothes” that refers to the clothing part of those meshes, so I have no idea how this could influence Blender behavior, but I see that it’s not just random, there is logic there, so I believe it should come from somewhere.

God only knows what Auto Rigger Pro did. It’s a complete black box to me.

Actually, @Blenderer gave the right answer. I made a test here and parenting objects in different collections does exactly that.

Don’t you have a previous save to revert to ?

I do have a previous save, but I wanted to know what happened for future reference. I actually figured it out. In the view layer, one of the object references is yellow and the other is YELLOW. Apparently one of those is your “real” selection. If you unlink the other one, it’ll delete the object. However, if you unlink the one you’ve correctly selected, it works fine. It’s easy to get them mixed up because they look almost exactly the same. So I just made sure to click on the one I wanted to delete and then unlinked precisely that one and it worked. Make sense? Thanks again for your help. I’ve already marked your earlier answer as the solution. I’ll heart it too for good measure.

Autorig pro does its own thing, I’m not surprised it does weird stuff in the background for whatever purpose… I guess you could ask the author if you’re curious about its inner workings (“lucky” on this forum)

1 Like