What did I do now? Colors Replaced Background Images

What did I do now?

I have no idea. Would someone tell me what I did and how to fix it? BTW, ctrl+z didn’t work.

I was scrolling the mouse up to the drop menu to save the file when I clicked the mouse. I don’t know which button I actually hit, though.

The pretty colors have replaced the backgroung images, but I can still rotate the mesh while middle mouse clicking and that view fuctions as normal. Also, the History button isn’t showing anything when I click it.

I’m using Blender 2.59.
I’m afraid to touch anything else until I get a response, for fear of messing up things further.

Thank you,


File > Load Factory Settings.
Remember to safe your settings afterwards Ctrl + U


Now that is something i have never seen before, i think it really looks like some problem between Blender and your graphic card driver to have all the icons being replaced by colored squares like this. Because i don’t think there’s a button in the Blender menu that does this by just clicking on it.

Any specific reason you use Blender 2.59 instead of the latest stable Blender 2.62 ?
Since 2.59, Blender 2.62 do not only add a few features, but have fixed with time lots of bug (one may have led into that bizarre thing you have in your screenshot)

" File > Load Factory Settings.
Remember to safe your settings afterwards Ctrl + U

~Wentzel "

Thank you much, but I already tried that with no success.

It could be your graphics card like @Sanctuary said.
Did try any other Builds ?

I tried Blender 6.1 and was having problems, so I decided to use an earlier version. I loaded 5.9 and am using it from my flash drive so I can work on my projects on different computers. Blender 5.9 has treated me well thus far.

I have no idea about the graphics card, but I’ve never had a problem with it before.

This is the first and only project I’ve ever worked on. I’ve built this mesh nine different times over the past several weeks and I’ve never run into this problem before.

Maybe try 2.62 or a latest build from GraphicAll.org.

2.62 is really stable from my point of view, they fixed 205 bugs which might be one of those your facing.
Other than that, i have no clue what the problem is, Hope it works out.


I figured I’d give the forum a shot to see if anyone out there has ever encountered the problem.

In the meantime, I have some programming assignments to complete while waiting for some possible solutions.

The worst case scenario is that I’ll go back to a previously saved file and tweak the abs before moving on to extruding the legs.

I don’t know if I want to use a newer version of Blender because I have everything set up to use 5.9 on my USB drive. How much of a hassle would it be to upgrade the program on my USB? Do I need to go through creating a new “config” file, repointing my paths, and all that jazz?

You should just need to create a new folder named " config " (minus the quotes of course), put that folder into the " 2.62 " folder of the Blender directory you’ll move to your USB key and you should be set, Blender should then save its settings there.

After that you shouldn’t need to, but if you want to type specific path in the File -> User Preferences -> Files tab , it shouldn’t take long.

Very cool. Thanks for the instruction!

I recently talked with a programming buddy here at school and he said it “may” be a rendering issue with the Blender windowing framework. In short, something went screwy with the program and the images and icons were replaced with random colors.

It looks as if I will be working with the backup files because there is no fix to this problem.

Life is still good.

In case this strange problem occurs again for you, go to File -> User Preferences -> System and try to change “Window Draw Method” that is by default set to “Automatic” to one of the other available settings to see if it works better.

Note : depending on what you have as a graphic card and what setting you have changed “Window Draw Method” to, it’s possible that going again to File -> User Preferences just crash (by example if you have an Intel there are lot of chances it will do that).
In such case, just change the 3DView into the User Preferences

there it will not crash, so you can change to another" Window Draw Method" or revert to the default “Automatic” in case nothing change for the better.
Then you’ll have to revert the User Preference icone to the 3DView one in the list from the screenshot to get back to the 3d view

I had to take my chances with a reboot and the good news is everything is back to normal. I’ve got one more program to write and it’s back to my 3-D model. Bring on the legs!

Thanks again to all who responded!