What does the popupat the beginning mean?

I know I’m not the only one who gets this, because my friend gets this on his computer. Is there a problem with the popup? or does everyone get it?

That’s the console window. Everyone has it (at least everyone that works on Windows, i don’t know for the rest)…
It says that you haven’t installed Python, and that some scripts, that need specific Python modules probably won’t work. It’s not a very big deal… Blender will work just fine…
My suggestion is to install Python ASAP, you’ll probably need it if you use the scripts…
You can Goolge the latest version…

Not the latest version, zazu. He needs version 2.4
Newer versions won’t work with Blender.
But don’t worry,Scotchtapeworm, the most basic python scripts will work so unless you’ll use a lot of scripts, you don’t really need python.
The console window also gives you info when doing various things like when rendering with YafRay.