what happened to the Blender PPA?

ok, so I love the fact that I can update blender whenever a new feature(s) come out, so I always downloaded it from the PPA. But as of today, it hasn’t updated for 15 weeks. And I KNOW that there were new stuff added to blender. Is it because it was switched to git? if so, how do I download it from git? I feel like I will mess something up with the main server if I follow the instructions in this page (I’m not very good at doing the scripty stuff, if that wasn’t obvious already). I just want to get the new features, not develop 'em :stuck_out_tongue:

Why not just use the buildbot? Pretty sure that’s the preferred method of getting current vanilla builds these days if you’re not into building yourself.

but that way I’ll have to download it manually D:
besides, that way, the new features wouldn’t be available if I would double click a blend file. I would have to navigate to the blender app, then open the blend file. I know it’s a silly thing, but simply double clicking the blend file is way more convenient :stuck_out_tongue:

Thats realy unfortunate that Ubutntu doesn’t give a damn about anything other than the latest Firefox in their distro. They could atleast update to all stable packages but no…

Anyway, if you don’t want to build yourself you could automate it through script put it in autostart and create an icon to associate with it then pick it in file assosiation stuff as default program to open blend file and you’re good to go.

Change /dev/shm/blender_fresh to where you want this stuff to store

#!/bin/sh

bpath=/dev/shm/blender_fresh

arc=$(uname -p)
case “$arc” in
*64) arc=64 ;;
*86) arc=86 ;;
esac

path=/dev/shm/new_blender_fresh
if [ ! -d $path ]; then
mkdir -m0700 $path
else
if [ “$(ls -A $path)” ]; then
rm $path/*
fi
fi
cd $path

latest

find latest stable blender in blender.org

wget -E -H -k -K -p -nd -q --accept=html http://builder.blender.org/download/
link=$(grep -i “linux” .html | grep $arc | grep tar | sed 's/^[ ]//;s/[ ]$//’)
link=${link##<
‘href="’}
link=${link%%’">’*}
echo $link

rm $path/*

test -d $bpath && mkdir $bpath

wget $link

tar -xjf tar
rm $path/*
mv * $bpath

Some extra info might help…
What is your build environments? I’m going out on a limb, windows? are you using msvc 2013? Are you using cmake or scons?
Have you installed Git? Sometimes I will use TortoiseGit not required though.
create a folder example… D:\ehabcharek_builds runk, right click on the trunk folder, select git bash.
Now that your in the git terminal, copy and paste…

<b>git </b>clone <b>git</b>:<b>//</b>git.blender.org<b>/</b>blender.git

This will create your blender directory
Now type… cd blender
(or Right click on the blender folder @ D:\ehabcharek_builds runk\blender folder, same thing select git bash)
Now type and enter the each of these…

<b>git</b> submodule update --init --recursive
<b>git </b>submodule foreach <b>git</b> checkout master
git submodule foreach pull --rebase origin master

Now you have the main repository (Not all of it that you need though)
Currently you still have to use svn to get the libs required to build blender
Now we need to create a new directory. To do this you can open your VS2013 x64 command prompt and change the directory to the D:\ehabcharek_builds runk
at that level
you enter this…

<b>svn</b> checkout https:<b>//</b>svn.blender.org<b>/</b>svnroot<b>/</b>bf-blender<b>/</b>trunk<b>/</b>lib<b>/</b>win64_vc12  lib<b>/</b>win64_vc12

Now you have new folders with the libs required at D:\ehabcharek_builds runk\lib\win64_vc12

Now to update the repository, you use git bash(in the D:\ehabcharek_builds runk\blender folder) and enter each of these…

<b>git</b> pull --rebase
<b>git</b> submodule foreach <b>git</b> pull --rebase origin master

To update the libs, change the directory in your VS2013 x64 command prompt to the D:\ehabcharek_builds runk\lib\win64_vc12 folder and type…

svn update

Now you have a full repo…

Hope that this helped some.

Cheers,
~Tung

Not to go too far off-topic, but that’s why I gave up on Linux. Windows may be owned by an evil corporation, but it’s brought up-to-date at least once per week.

I recommend using KDE (Kubuntu, OpenSuse, etc) it is highly configurable. Associating file extensions in KDE is as easy as this:

Download Blender from buildbot. Extract the contents to a new folder. For example /home/YOUR_USER/BlenderBuildBot

1- Open the file browser (Dolphin)
2- Right click on some .blend file. Open With > Other. You will see a window like this:

3- Top right click the button with a folder icon and choose the path and the “blender” executable file (/home/YOUR_USER/BlenderBuildBot/blender)
4- Check the last box “Remember application association for this type of file”

When you want to update you’ll only need to do from now on is to download Blender from buildbot and extract the contents to the same folder.
In addition, there are more options for file association in KDE system settings.

If you insist on Ubuntu, look for something on “Ubuntu Tweak” and file associations, but I think anyway will not be as easy as in KDE (Maybe someone should open a report in launchpad about how hard it is to associate file extensions in Ubuntu)

@YAFU
What I’ve seen of KDE looks terrible. Cinnamon is the way to go in my opinion.

@ehabcharek
Lately I’ve been using the buildbot versions (I need pie menu’s). I just make a link, and add it to the desktop or the bar at the top (customized cinnamon).

When I was running Ubuntu several months ago, I just put the link on the desktop and it worked perfectly fine for me.

KDE is highly configurable and you can give it the look you want. Anyway if Cinnamon is easier than Ubuntu/Unity to associate extensions, then this would be another good choice.

For whatever it’s worth, that isn’t a Linux thing but just the way Ubuntu and its derivatives do it (which is one of the reasons I don’t use them). Manjaro is a preconfigured distro that you can get the latest and greatest software on as an example.

Regardless of distro, building Blender on Linux is really easy though. Maybe I’ll make a video on it when I get time.

@xrg
That would be great.

I used to run manjaro, but I found that it was a bit unstable being based off of arch.

Also, the linux mint repositories are pretty up to date. Without installing the ppa (a few months ago) I got Blender 2.68/7/9 (I can’t remember). I think firefox updates by itself though.

We should stop discussing this though. I think it’s a bit too off topic.

Oops… linux,
i know not what i say…

+1 on the video, can’t wait!!! I am struggling hard also myself getting repo’s and installing dependencies and doing this and that, pfff

I think a text tutorial to copy and paste would be easier to follow.

Anyway to clarify to new Linux users, you only need to compile if you want to learn or in very few cases.
There are many options for using Blender 3D without compiling: Packages from your Linux ditribution, external repositories, official Blender binary. To test new features in unstable Blender versions, binary from BuildBot or GraphicAll.

There shouldn’t be the need for a tutorial, on Linux, the wiki docs should suffice, if not, then we should improve them.

http://wiki.blender.org/index.php/Dev:Doc/Building_Blender/Linux

@ideasman42
The wiki works but isn’t good for beginners. It seems to me like it’s just good for more advanced users who are used to building programs from source.

An update to it would definately be welcome.

@TARDIS Maker it’s like… you know me! o
I’ve never compiled anything before, and all the tutorials assume that I know, and have downloaded, compilers and other stuff, so yeah. More info for beginners please!

@tungerz thanks for that, I’ll try it on my windows 8.1 laptop, but I was talking about Ubuntu linux :P… I should have probably mentioned that

@YAFU ubuntu has almost the same thing. It doesn’t have the command part. we need to edit a config file to achieve the same thing though
EDIT: we can install ubuntu tweak to do this. I just did it and it works :stuck_out_tongue:

hey guys, I eventually found this PPA that worked for a while, though for some reason it stopped. Now, on the website itself it shows that it’s been updating almost daily, but for me it hasn’t updated in months! (and yet I only realized that recently -_-) I tried to remove the ppa and re-add it, then updated and upgraded everything… Still nothing. When I tell it to install blender it says it’s on the latest version. It’s never happened to me before. Does anyone know why this is happening?

Did you install ‘blender’ or ‘blender-edge’ ?

‘blender’ hasn’t been updated since April.

thank you very much, that was it! XD

I should be used to it by now, but I still manage to get surprised by my own stupidity very frequently -_-