What is the problem with this face? (flat face shows a line/reflection)

There are some relection-like lines in the GRASS tiles. The mesh doesn’t have anything special in that spot, and it is only on one side. I thought that it might be a problem with the material/skin/lighting, but someone told me that the models get imported into TABLETOP SIMULATOR (that’s where the image was taken) without lighting etc. and that the TTS does its own lighting. So what could be the source of this imperfection?

This is the .svg posted on pastebin in raw-mode:

Should I post the blender file?

It may be a shading problem. It would be better to post the file.

Here it is. I showed it to one person that is way better in blender than me and he found nothing in the blender file, so he said it might be because my unwrap would be overlapping. My unwrap never looked as i it were overlapping, but I can’t really tell. I will re-unwrap and reskin today and check for that part of the problem.

here is my Blender file: https://dl.dropboxusercontent.com/u/226592/TTS/Experimental/Hex_calculated_proportions_with_seam_textured_no_tree.blend


Here’s the file. I posted it already, but that post was never released or my connection was bad.

The blend file looks nothing like the original image (a single hexagonal cylinder) and includes no textures in the file.

To ensure full export compatibility get rid of the ngons (faces >4 sides). Use quads and/or triangles

You could modify your unwrap like this to max use of image. Other than that - i don’t see any problems with what was in your file. Lessen glossiness a bit if it’s needed here at all (use shadeless?).

I removed all textures from the .obj that is used in Tabletop Simulator and this is what it looks like:

A newly built hexagon doesn’t have this strange line, so I can repair it, but because I’m learning blender I’d really like to know what kind of mistake caused this line.

The blend file shows 1 hexagon, that is correct. I put them together in Tabletop Simulator for the screenshot. TTS has its own lighting I was told, but other hexagons I did didn’t have that strange reflextion while having the same settings.

How did you get those beveled edges? Is that just the grey lines from the UV unwrap showing through or did you edit it a bit further? Edges look very nice. And is that material in blender? I never saw the grass thing. It’s not a material but a skin, right? Sorry for newbee questions, I can do the basics now but I want to be surewe don’t talk past each other.

Lines is Bevel modifier, look in modifiers list. Before you do i’d recommend apply scale to hex: Ctrl-A - Scale (in Object mode).

Material is the same you had - this is texture image which changes the look - see on the right side in UVeditor window. Image came from here on forum earlier shared set from Josip Kladaric - 1024x1024 pixels, tileable. I took UV islands from your unwrap and scaled them as you see, then using blender’s paint mode paint and the same image as a stencil texture (wow o_O, no circular reference errors!) painted side faces. Saved painted image Save As and used as a texture for Material. Since top face now covers a lot more pixels in texture image rendered look is better.

I have no clear idea why you have this shadow on top face but this likely can be repaired by deleting face, selecting loop of verts and Space key- “grid” - this will bring GridFill command which will fill top properly with quad faces instead of n-gon.