WHAT is the purpose of CAMERA CLIPPING?

Hey,

Is there a reason and use for this camera clipping? It seems LIKE EVERY SCENE , its
way off and I have to reset it to MAXIMUM!!! { super annoying}

thanks

Here’s my understanding of it:
It has to do with something in programming called floats. To put it simply, computers aren’t perfect. a number like 3.5 might be 3.4999826 in computer language. You can imagine the problems that would occur from this. If one face is 0.35 BU away, and another behind it is 0.349 away, then the computer or GPU can get confused and think the one behind is actually in front, and draw incorrectly. Normally, this is unnoticeable, as the range is between 0.1 and 1000, and faces are sufficiently far apart from one another to have a margin of error. But if you make the range bigger, like 0.001-10000 BU, that difference gets far smaller to the computer, as the distance is relatively smaller. When that happens, faces on the inside will start drawing on the outside, Z-fighting galore, etc.

Don’t beleive me? Here is a basic scene. The magenta plane is 0.001 BU above the Blue one.

http://www.pasteall.org/pic/show.php?id=21433

http://www.pasteall.org/pic/show.php?id=21432

is there anyway to DISABLE THIS CAMERA CLIPPING?? or remove it from Blender.
I have just wasted another 30 minutes trying to set it.

IF YOU ENTER ALL 99999999999 to try and max it… it is BUGGY and goes to 189… horrible. get rid of this !!!

easy on the capslocks :slight_smile:

in short, what Captain_P tried to say is:
a clipping range for the camera IS NECESSARY, at least for the realtime preview. The narrower the range is, the more precisely the z-buffer calculations will be (less z-fighting and stuff).

sorry if that doesn’t solve your problem (reality hits you really hard), but you may just wanna set it to something that covers your average scene and save it as default in the user preferences.

in short, what Captain_P tried to say is:
a clipping range for the camera IS NECESSARY, at least for the realtime preview. The narrower the range is, the more precisely the z-buffer calculations will be (less z-fighting and stuff).
I’m not Captian_P

:wink:

Im captain P - lol

thanks for explanations, both, but I still find it more than aggravating. I dont find this in Lightwave, MAX, or XSI.

Camera clipping is one of the best features in Blender, I don’t think it’s going away. It’s very useful when modelling and also a quick hack for finding distances. Just set Start to 0.1 and End to 10000000 if you don’t want to see it.

thanks hopefully I will see the value someday. In the meantime, have you tried
inputting those numbers you suggest? I find they dont input like that.
It is very hard to set a large number in there, without endless dragging of the mouse!

Blender, 3dsmax, lightwave, XSI and every other tool has camera and viewport clipping.
DirectX as well as OpenGL both have a view frustum and that´s that.

And the bigger the frustum the lower the precision, just like ol77 explained.

And to set a large value you don´t drag anything, you click the field and type 9999999999999999999999999999999999999999999999…
It´ll cap at the hardcoded maximum possible after pressing enter.

sry, dude :slight_smile:

maybe so, but in those other apps not once have I suddenly been lost cause the
camera distance is so short I cant see any of my models!

I know that, or thought I did…but in 260.5, its not working!

thanks

Just tried arexma’s suggestion and here’s what I got:


Also, if you select the ‘limits’ option in the camera panel, blender draws a line from the camera to the end of it’s vision, or what can be seen from the camera. I used blender 2.60a from blender.org to create this…

Randy

I use metric measurements and stick to them for consistency. That is for me that 1 metre means 1 metre. The first time I came across this problem was when I recently started building a ‘real size’ cathedral. If this issue is happening frequently maybe your scale is large? I’ve never seen this problem with ‘domestic’ objects. Just a suggestion.

In Lux you can use the camera clipping like an effect to show interiors of architectural renders.



http://www.luxrender.net/wiki/LuxRender_Cameras

[QUOTE=Artales;1994883] If this issue is happening frequently maybe your scale is large? /QUOTE]

yes i think this is the basic problem. And a big problem for BLENDER new users!
Because most people coming from another app will bring some of their own models
to test. And when they start with blender, the camera controls are very weird, plus
the navigation controls are very weird ----- then when THEY SEE NOTHING — cause
of this default scale problem + camera problem ----- they will give up and tell everyone Blender is too hard… etc.

The default camera distance should be 999999999999999999999999999999 IMHO.

The default camera distance should be 999999999999999999999999999999 IMHO.
At least we’re fortunate that your views have absolutely no bearing on what the defaults are.