What...whatever is it doing in Cycles?

OKAY, SUNNY must be missing something here.

In Blender 2.6.5, if I put in an environment texture, it’s all, “SUP!!!” And it works.

But with the 2.6.6, I just get a flat color. So, either I’m doing something wrong, or, you know, maybe I’m just hallucinating. :stuck_out_tongue:

(I just realized I might have posted this in the wrong place…sorry! Still…trying to…get the whole…change…thing…)

EDIT: I wanted to note it DOES show up when rendered, but, not in the viewport. It just has…flashing colors when I rotate it. Also, I’m on Windows 7 64 bit.

Check ‘sample as lamp’ and see if that fixes your lighting ?

Are you in orthographic view?

I. I have absolutely no idea where that is, AHAHAHAHAHA. (Maybe I should…click more buttons more often?)

No, I’m not in orthographic.


first image you loaded, lower right is the settings for your environment texture, bottom show not selected as sample for lamp…

It’s the second one I’m having trouble with.

I don’t see an option for that on the right. The only thing under settings is “multiple importance sample.” Unless it’s somewhere else is 2.6.6…

Moved from “General Forums > Blender and CG Discussions” to “Support > Lighting and Rendering”

Sample as lamp isn’t going to affect this-it’s just about efficient sampling and noise reduction. Could you share the file? It’s hard to tell from this. Try to switch the background to the sky environment and see if it works. Then try to switch it back to your map.

No, I’m not in orthographic.

Yes you are. Press numpad 5 and I’m sure it’ll fix your texture :wink:

Sorry, but, pressing 5 does nothing. :slight_smile:

I also tried the sky environment before, but, still, nada. T_T

Where can I upload the file? I totally forgot the name of the website generally used.

Numpad 5, not just 5 above your keyboard. Numpad 5 takes you to ortho or perspective, and you need to be in perspective. You can check it in your header menu under view as well. I tried with an image on my machines, and all three work as expected in perspective view.

I know that. :stuck_out_tongue:

And that’s what I pressed.

pasteall? maybe that is the site you are needing

I hate to repeat what everybody else has said already, but that looks exactly like ortographic view.
Have you tried you to change Ortho/Perspective in the menus as well? Just to eliminate the risk of it being a keyboard issue. You find it under the “View”-menu in the 3D View.