When recalculating normals doesn't work

Greetings. I have an issue where I made a chess rook out of a cylinder and when I set it to smooth, there’s these black lines (which happen to be the exact same lines as I see in Edit mode connecting the vertices) that I can see through the texturing. This happens even when I render it. I have tried to recalculate the normals, but it just makes things worse. Does anyone have any insight?

*Please see attachment for reference.




Check you haven’t any internal faces in your mesh and remove any duplicate vertices.


I was going to say the same thing as Richard. This is a classic sign of duplicate vertices. Select all and “Remove Doubles”, if that doesn’t work then it has to be internal faces doing this. The other thing is, that using smooth vs subsurface modifier are different. You may only be able to smooth everything out so much without adding more faces to the mesh.

Wow. Thanks for the reply! I will give those options a try and let you know how it works out.

Okay, I tried to remove doubles, but it made it worse. I don’t know what I did wrong here. (A, W, Remove doubles). I also, tried to set it back to solid, and use the subsurface modifier. It rounded the edges, but still have the same issue. I’m not really grasping the “internal faces” part of your advice. Any thoughts? Anything at all would help. Thank you in advance!

when “recalculating normals” don’t work, most probably its because the “mesh” is not “clean” ( check for edges or faces inside the object).
Anyway, if you do Ctrl-A it should solve the problem…I hope!

Okay, so it appears that I did have an internal face. I used it when i extruded the top most vertices to the center, then subdivided them (2x), then moved the center down creating a cup inside the rook (to get the 3D look). Otherwise the edges would just be flat. When I removed this “cup” it looked normal. However, now I’m completely lost on how to complete my piece and get the same 3D look.

Thanks for all of the help everyone.