Where is "make normals consistent" in blender 2.8x?

In 2.7x I never used the “recalculate normals” tool because “make normals consistent” tool (mnc) was so much better. The difference between the two is (I think) that recalc would adjust all normals and sometimes flip them to wrong direction. Pretty awful as sometimes it randomly flipped different areas upside down when all I wanted to do was to get rid of one or two flipped faces on a mesh. Mnc I think always just flipped the minority of faces to match the majority. Mnc was great as it always got those right and I never had to recheck anything.

Where is make normals consistent in new blender? I can’t find it in the spacebar search menu? Has the tool been deleted or renamed into something else? I can’t seem to find anything about it anywhere. All I found was that ctrl-n keyboard shortcut was changed but nothing about the tool itself.

Maybe my blender is just bugged somehow. Pressing “-” after setting a rotation (select an edge, press r, type 90, press numpad -) doesn’t invert the rotation. I have checked numlock so it is not that.

  1. Recalculate Normals and Make Normals Consistent in 2.7x are literally the same tool. The only time it can give you strange results is if your mesh has problems (duplicate vertices, internal faces, flat non-manifold, etc.).
  2. In 2.8x it’s Mesh->Normals->Recalculate Outside (default shortcut in ‘Blender’ keymap is Shift+N).
  3. If you just need to flip two faces, select the two faces and flip the normals, instead of recalculating whole mesh.
  4. Negating rotation works file here. Does the angle readout in the top left corner of viewport change when you press the ‘-’?
1 Like
  1. Are you sure they are the same tool?

  2. If I have a big mesh I don’t want to find the flipped faces (if there even are any) using whatever tools I’d need for that. Be that manual search or using the finder tool in blender that finds triangles. And then flip just them. It is billion times faster to just run the tool make normals consistent everytime I had edited something. Running the recalc normals does not produce as consistent results but if they truly use the same code then it must be placebo!

  3. It just adds the “-” after the number. I did figure this one out tho. I had turned on a feature called “default to advanced numeric input” in settings/input/keyboard. Turning that off makes it work again. Kind of sad because I liked the idea of being able to write the equations there but the - for quickly reversing the rotation is more useful.

They’re the same tool in 2.79.
https://docs.blender.org/api/2.79/bpy.ops.mesh.html#bpy.ops.mesh.normals_make_consistent

The one that’s called “Make Normals Consistent” in the search menu simply calls “bpy.ops.mesh_normals_make_consistent()”, i.e. with the default argument, just like the toolbar button; and the one in the menu only passes the argument explicitly, still with the default value of ‘False’. All three do literally the same thing. Like I said before, if they’re having issues that’s due to geometry issues in the mesh (i.e. it’s ambiguous where “outside” is).


About the advanced numeric input: you can still use it even if turned off by default, simply need to type = before typing in the expression.

1 Like

Ok this is humiliating :D. Thank you very much for the info and the help though!

Well there’s something to be said about devs naming the same things inconsistently :slight_smile: At least they got rid of that confusion in 2.8x. And you’re welcome.

1 Like