Where on earth are the game engine object properties in 2.56?

I’ve looked everywhere for the object physics settings panel. I can’t find it in 2.56. I’ve looked all through the properties window and everywhere else I can think of. Where is it?!

While I’m posting, I may as well ask another question. How do I get shadows into the 2.56 game engine? I’ve tried a spotlight with buffer shadow on, textured view, and GLSL on, but I have no idea what that all means, and it doesn’t seem to be working.

  1. As to the Game Engine object properties problem, are you talking about physics? If so, enable the Blender Game render mode at the top menu (where File, etc. are), and then go to the Physics tab (next to the other tabs, Material, Object, etc.).

  2. You need to have a GLSL enabled card - if you’re sure that you have one, then make sure the spotlight size is a power of 2, like 256, 512, or 1024 (stick around there, as that increases the size of the buffer, making shadows more complex but also more expensive on the CPU). If you still have problems, post a screenshot showing how the spotlight looks and how the properties are set up.


Coolness. Thanks a lot. I found the physics tab.

I would get you some screenshots, but I have really slow internet and I can’t seem to upload them. The spotlight doesn’t even show up on the textured areas in gameplay. Is is because I have no material assigned to them, just UV images?


Oh. It did work.

That looks really interesting, Quacky. It’s a Lego game?

Yeah. I was inspired by the Lego Star Wars, Indiana Jones and Batman games. Except this is from the point of view of a Lego man in a real sized house.

That looks really cool - I’ve liked these exploration-type games a lot, particularly Chibi-robo, where you’re a small robot inside of a huge house. While some people might think that it’s boring, I think there’s some charm to exploring this massive place that we are all so familiar with. Hopefully your game turns out well - it’s looking good.

Oh, and make sure that you can go inside your lego house - I’d like to deck it out with furniture (or at least have it pre-decked, LOL).

You can go inside the house, but the camera view has problems since it is such a small area.

I still can’t do shadows. Why doesn’t spotlight show up on UV textures?


u could add an F Curve to the camera and put a invisible barrier around the house, so that when your camera is near or touches the barrier, it could play the camera animation and zoom in while in the house :slight_smile:

@Quacky - You mean shadow buffer shadows? Are you using GLSL mode with a material? Buffer shadows are the only kind of shadows in the BGE, and they’re only available for GLSL mode.

Oh. No, I don’t have materials assigned to most objects, because when I tried to add an image texture with GLSL on the object dissapeared entirely. The only way to get the texture to show up was to assign no material to the object and then UV map it. What am I missing?

If you have GLSL mode on, give the object a material, go into the Textures menu, add the UV image, and it should show up. Objects need materials to show shadows.

I got shadows.
Unfortunately, I have yet another problem. When I put an image texture on an object with GLSL on, the object vanishes. All it has is an outline in the 3D view, and it is completely gone in-game.

That’s odd. Can you post a screenshot? I’m pretty sure this has been asked before, but I don’t remember the answer.

Here you are. As you can see, as soon as I remove the texture the object reappears.


Why don’t you press P to see how it looks in-game? That’s all I can tell from the screenshots - also, ensure that your transparency value isn’t set to 0 on the Material menu.

I found out it works on my better computer. Maybe it requires a graphics card or something.
I was experimenting with buffer shadow. It’s working now, except the shadow goes away when the spotlight is far from the objects. I played around with the settings but couldn’t get it to extend the range of shadow. Does it have something to do with autoclip start and autoclip end?