Where on earth is the F-Curve to control interpolation of driver channels?? (rigify)

Hi all :slight_smile:

I’m having a bad time.

And for some reason this issue just does not come up in google.

This is a problem I’m having with my pitchi poy rig (add on for rigify) but if you know rigify you should be able to help.

I’m setting my animation interpolation constant because i want to work pose to pose on a character. Just so I can block out the animation without getting distracted by curve interpolation. So that’s working… but for some reason I can’t find where the IK/FK switch is hiding in the graph editor. It’s currently the only thing that is still using linear animation so it looks extremely odd when i flick through the key poses. I have to create double keyframes JUST so i can force it to interpolation in a constant way.

Question: How can I set the interpolation on the IK/FK switch. Or, how can i see it in the graph editor??

Progress update on the problem:

So after some hopeless crawling around to find an answer, i found that vanilla rigify has ‘snap ik/fk’ which i assume would give me the behaviour i want… SORT of, but maybe not. For the sake of trying things i went to look for it but apparently there is no such feature in Pitchipoy’s version.

So now I’m back to trying to figure out how and earth i can force blender to display those settings in the graph editor. Why would it not just appear in the graph editor?? It’s as though editing driven curves in Blender is moon logic.

OK Problem solved after spending half the day trying to figure it out:

Here’s where i finally found a solution:

In case something happens to that link, let me quote the original poster here:

i am using blender 2.76 on win 8.1 x64. if i create normal metarig, generate and select arm control and insert keyframe with RMB on IKFK parameter in property bar, i get keyframes start showing on 'newly created action in dopesheet or fcurves. where as similar behaviour on pitchipoy meta rig , generate and attempt to keyframe IKFK parameter doesn’t show keyframe / channel name in fcurve. it shows a keysframe in dopsheet main action (top) but i can’t move it, and no special channel is added, i can’t see that in time time or fcurve. any ideas would be appriciated.

[TABLE=“class: fw, width: 660”]
[TD=“class: vt”]shareedit
asked Nov 16 at 11:30


add a comment


1 Answer


up vote1down vote
Ahh, i found solution. If anyone is in same situation. rig maintain ALL IK FK switches and stretch options at end of dopesheet (mostly hidden) you have to make sure, following

  • mouse icon “showing selected object channels” is OFF
  • ghost icon “include channels from bone hidden etc” is ON

now when i know this, i think its very reasonable to have them there separately managed. this behavious is slightly different than rigify but good enough. thanks pitchypoy for awesome rig.

Please forgive my weird copy and pasting techniques

Many thanks to OP: Iala.