Where to asign a hotkey for "Display modifier in edit mode" (Subdivision surface)

I tried the fast metod by right clicking the button in the interface and asign a custom hotkey but it says Non keyboard shortcut. Ive searched for this in the preferences but couldnt find it. I want this mainly for Displaying the subsdivision surface modifier, I dont think I want this for all the modifiers. I wonder if its possible to turn on and off by hotkey only this modifier or if its possible at all.

It works in 2.80 here. But it’s a bit tricky.

You add the modifier, make sure the name is what you wan as it will get bound into the shortcut (“Subdivision”, “Subdivision.001”, etc.), then right click the button and select “Assign Shortcut” and a popup with a button will come up.

What you need to do at this point is to hover the mouse over that buttopn so that it turns blue and says “Press a key” and then hit the key (with any modifiers) that you want to bind.

But if you CLICK on the blue button then it assigns the left click to that operation, and if you right-click again it shows you the “Non keyboard shortcut” text. I can’t even find where this gets set in the keymap preferences, so the best option at that point if you don’t have a lot of custom keymaps set is to go into Preferences -> Keymap and click the Restore button that should return the keymap to its default state:

image

Alternatively, if you haven’t exited Blender yet, you can disable Auto Save Preferences and quit, and then restart Blender and it should be back where you were before you started the last session.

1 Like

Ok, the modifier visibility button keyboard shortcuts go into the Keymap under the “Window” section as “Context Toggle” items that will contain an expression like:

object.modifiers[“Subdivision”].show_viewport

if you need to hunt them down and exterminate them manually. You’ll probably find one there as a Left Click bound shortcut.

Reported as https://developer.blender.org/T65171

Which Brecht closed as “it’s always worked this way so not really a ‘Bug’”.

So watch where you click :slight_smile:

You can insert keyframe for display or hide sub-D.

Set Start frame 1 for display sub-D.

Set End frame 10 for hide Sub-D.

Press Shift Left Arrow or Shift Right Arrow as shortcut of display or hide sub-D.

Also you can change keymap for shift left arrow in

1 Like

It seems to work for object mode.I assigned it the “><” key since its close to the modifiers (Shift, Ctrl) But for the Edit mode the Asign shortcut option for the button is missing. How to set it for this ?

Edit mode doesn’t make a difference for me here. I can assign the shortcut in Object or Edit mode, and after that it works in both object and edit mode. It’s possible you’re assigning a key that has a conflict in the edit mode keymap. I was testing using F10.

the “creativity” of Blendheads really amaze me

image

image

wrong expression ?

[“Subdivision”] = Correct

Fixed.

I was just pasting an example of what the generated shortcut looks like, and something converted to smart-quotes in the process. I didn’t expect anyone to try to set it up manually from that :slight_smile:

1 Like