White Worlds

Ok, weird newb question here…

I am attempting to render some models and am going for the unsurfaced model on a white floor, in a white world, look…with shadows.

I am just having problems getting the all white world to look right, I tried setting up two planes, one floor and one wall, but I can see the joint where they meet, and the back wall is very dark cuz my light isn’t reaching back there and I don’t really want a back wall…just an infinite white floor, well lit, in an infinite white universe, am I making any sense?

I am very new to blender, and have little 3d experience…but I am stoked to find such a great community built around such a great product.

Many thanks, look forward to posting some of my work and continuing to be awed and inspired by you guys…

So, basically, you want a white scene kind of like the Matrix load up program? If so, there are two suggestions. In the materials, which I assume that you have turned white, you can hit the button that says shadeless. Your walls will now be the exact color that you make them, uniformly, and are not affected by light. However, unless you need a floor for reference, I would just make the world white. To do this, go to the material settings, then click the little world, globe button. Then just move all of the sliders making blue, over to 1.0 for white. If you have more questions, or this isn’t realy what you meant, feel free to describe in more detail what you want.


the floor you can keep if need be… just scale it up to where it goes to a point where it seems to reach that endless point… as for the walls… kill them… like affore mentioned… make the world setting itself white… as for the light being a problem… switch from general lamp to “Hemi” and that should get rid of most your problems… at least realy imply the overpowering whiteness of it all.

Try making a white world background, and give your floor plane a material with ‘only shadow’

You mean that you have made the setting for a good white material but you don’t see that it’s white because the light doesn’;t reach everywhere and you want everythign everywhere to be as white as everywhere ?

In that case maybe try Global Illumination, or a sun lamp wich lights the whole scene. You can also make the white material shadeless ofcrouse but then you will not see any shadow and it will look flat.


Many thanks…I achieved the look I was going for with making the world white, and adding a huge white plan as a floor, plus some global illumination and a spotlight…

now, this is something else I have been trying to accomplish…soft shadows, my shadows are very crisp, but I want to soften them up, is this a light property I must modify, or the object casting the shadow, or the object which the shadow is projected on?

Thanks again, what an amazing community.

since you say that the shadows are crisp, I’ll assume that you’re using a ray shadow lamp. This makes a very sharp shadow.

The simplest “soft” direct shadow is to use a spotlight with a z-buffer shadow. You’ll have to tweak some settings and the clip values. This is the fastest shadow, but is uniformly soft. Play with the bias, samples, and soft settings until you get what you want.

If you want a kind of global shadow, u can either use AO (need fairly high samples though) or a fake gi dome. The Ambient Occlusion menu is in the world settings. GI dome is somethign that you have to set up yourself.

The other direct soft shadow method is the area light. for good results, set the smaples fairly high, 8-10 +, along with the jitter, dither, etc options. You’ll need to make the lamp power really low though. Tweak settings and size until you get the effect you want.

For both AO and the Area light, the Ray setting needs to be activated.

I think the best look would be with a GI dome. If you need a directional shadow you can just sibdivide part of the icosphere. If you use the search function, there are probably a couple threads that explain how to set one up. If you need help, you can, of course, ask.
of course, depending on your needs, you may only need a spotlamp soooo, whatever works.

For soft shadows, you can use ‘Area’ light instead of the regular ‘Lamp’ light; choose a circular or a square area light, and then orient it like you’d do it with a regular ‘Spot’ light. be sure to turn on the ‘Ray Shadow’ button in order to access to the sampling options (beware, too much sampling can give very long rendering time). Of course, if you turn on any Ray option, then you have to set (in the Render buttons) the Ray button.

Hope this helps,