whole keyboard "marchs" through numbers 0-9 when typiing into an input box.

Okay I’ve posted this in the Support/Basics & Interface forum and have only had one reply. So here I am in the Python support. Blender does not recognize keystrokes as there assigned character. If I press G to grab and move an object it switches to layer 2 when I go back and try again it goes to layer 3 and so on. When I go to enter numbers manually in an input box I could type any characters and the result is; 567890123467890123456789. I’ve tried resetting blender presets and get this error;

I’ve uninstalled and reinstalled blender, trying to wipe this problem away and start over with no positive results.

Any help would be greatly appreciated!


I’m shooting in the dark here, but does your username have some extended characters like umlaut or accents?
Have you tried installing blender to c:\blender25 just as a test?

failing that I dunno. What language/locality do you have your OS configured to be?
I fear that the errors we see in that list are really only the very last errors in a long list of errors caused by one small ‘fact’ that seems to have derailed your entire installation.

No umlauts or accents in my username, I just finished installing and testing blender on C:\blender25 with the same results. My OS (windows xp serv pack 3) is set as English\North America.

Is there a way to clear\wipe python from my system and start fresh? Like this is the very first time blender has been introduced to my system?

Yes you can uninstall Python from the control panel or the uninstaller. Don’t know why that would cause the keymappings to go out the window though. I don’t use installers anymore with my windows partition, since there always seems to be something left behind that messes with something else. I would unzip an archive that you would get from graphicall or blender.org to a directory of your choice and use it from there. The archives have python packaged with it, so you don’t need to install it and Blender stays pretty much self contained in whatever directory you unzip it in, plus for Vista and Win7 users, they don’t have to deal with permissions all of the time.

Okay, I feel like I’ve tried everything…I’m starting to lose it. Why isn’t there some simple answer for this? I don’t get why this isn’t a simple uninstall\reinstall fix…I’ve gone through and deleted anything that had anything to do with blender and used the archive instead of the installer.

If something has derailed my installation how do I get it back?!?!?

I was just getting used to all the hot keys and getting fairly proficient with blender and taking away the hot keys puts me back in the stone age with this software.

If you’re using windows your first action should Always be to scrub down your computer whenever a program starts acting badly. Macintosh is less vulnerable, and Linux is least vulnerable, but still; Programs only start screwing up because something has gone wrong. With especially stubborn screw ups that persist through re-installs it is usually a good bet that the ‘gone wrong’ is malignant in nature and comes from some human(s) attempting to make their own use of your property in some way.

Use your anti-virus program as thoroughly as it allows, also for Windows a good prog to use is Spybot-S&D, and use any other anti-malware programs you might have. (I included Spybot-S&D’s link because there are some similar looking/sounding sites that are less than reputable).
It sounds like your comp is getting its key-stroke messages screwed with Before it reaches whatever instance of Blender you are trying to use at the moment, in a way that Blender cannot recognize.

Remember; Windows are the most breakable and least secure part of the walls of your home. the same thing holds true with your computer. (as a word of caution; That doesn’t mean you don’t have to lock the door, in either case.)

I have Norton suite 5 and all it found were some tracking cookies. I’m I going to have to format my drive to fix this because I just did that about a month ago to get my wacom tablet to work and I’d rather not have to go through that process again.

Interesting issue I must say…

Although PLEASE whoever that was, don’t blame windows. Windows is actually better than people make it out to be bla bla bla bla bla it’s not like you care about someone who actually uses windows because you are so biased anyway so I will stop typing about you.

Are you absolutely sure that you are using a version straight from Blender.org? Or are you trying another build from Graphicall or another website?

I grabbed it right off of Blender.org, it’s version 2.57.1

I feel that this suddenly happened too. One session it was working fine, the next it just wants to walk through layers. Could this have happened because I pressed the wrong hot key? For example if I tried to remember a hot key and just guessed at it. I wouldn’t think that would possible to do though. Like Hmmm I think that was P, nope Ctrl+Z, Okay lets try again L, nope Ctrl+Z.

I remember that Ctrl+N used to do some freaky stuff… Not that weird though.

Just open it up, reload factory settings. Little things often seem redundant but can help anyway.
(And yes, this even applies with a fresh install. Because the startup files are kept “off-version”.)

I just uninstalled, reinstalled and reloaded factory defaults with no change in keyboard input…It still gives me the long string that is pictured at the top of this thread if I try and change the presets from the splash window.

I can’t figure out why this is such a persistent problem…

So basically this problem has never happened to anyone else on this site or any other forum I’ve searched.

Is this a python file issue, a blender issue or a windows xp issue? Can anyone give me an educated guess?

The reply’s on this thread have been helpful in giving me ideas of what to do, unfortunately they haven’t been successful at fixing this problem for me.

Well, darn!
I think that one clue might be the line in the output you first posted:
“AttributeError: ‘UserPreferencesInput’ object has no attribute ‘invert_mouse_wheel_zoom’”
I remember with my XP experience,
(yeah, I actually DO have, and Have had, windows OS’s, Do know what I’m talking about, AND I even have testified in court - many years ago - on Microsoft’s behalf … for which I am now terribly sorry. but thats a story for another day/thread/and forum.),
that I was clumsy enough to constantly get some of their things like ‘Sticky Keys’ turned on and that the special needs, or just user customizations, really screwed with some of my programs.

So, we have to ask if there is any Mouse related changes you remember making when this all started?

You mentioned that you had trouble with installing your Wacom,
(I just got a bamboo Wacom and it put a damned on screen keyboard on my Vista sign in screen… I have No idea how to remove it, I just live with it when ever I use that OS. It actually works better on my main Linux OS though it was harder to set up),
That Waycom might be a place to start investigating since we have dispensed with the normal mal-ware issues windows (especialy XP) is a magnet for.
Did you get the proper Wacom Drivers for XP installed and up to date?
Is there some tablet/mouse functions that might be turned around, (or, like I did once, is something sitting on your wacom or another mouse that’s plugged in. :slight_smile: it would be so nice if it were That easy!).

Let us know your progress Evaler.

I’ve gone through and made sure both windows xp and wacom are up to date. They have been the whole time, nothing new to update to. I then checked the settings for my tablet and couldn’t find anything pointing towards blender. Just for good measure I reset the tablet to factory settings, with no change to the way the keyboard is functioning in blender.

Also I started up GIMP 2 and tried they’re hot keys (N for pencil P for brush) and they work. I also tried changing different text inputs (e.g, zoom level, brush size) and the keyboard also functioned properly there.

You pointed out the inverse_mouse_wheel_zoom line in the error message, when I open the user preferences / inputs there is an import key configuration button. Now there should be a file I can load there as the factory settings file, right? I’m just not sure where to find it and if it would do anything different than Load Factory Settings in the File menu.

That is good, you should give it a second look with the idea of scanning for changes in your mouses behavour that other programs might ignore (or handle differently so as to not be a problem to Them).
That is just an investigative path that should be evaluated as ‘Open’ or ‘Closed’.

On that same page you were on in Blender (open Blender and then press keys; [Ctrl]+[Alt]+[U])
go to; <Input> tab
Check the settings in the attached pic.

Even If Your settings there are exactly like mine;
Change them, Save As Default, THEN Change them back again — and re-Save As Default
Once you get them set the way mine are and you hit your “[Save As Default]” button, close&reopen Blender and see if there is a change in behavior.

IF there is no change, then try; Checking the “[ ]Invert Mouse Wheel” box

  • hit [Save As Default] again, close&reopen Blender and see what THAT does.

IF nothing else all this will, at least, supply a greater amount of pertinent info for the Tech’s in the bug forums if we have to send you there.


Sorry it took a couple days to get back to you on this Dan158. I tried your above instructions and again there is no change in the actions of the keyboard. There are some hot keys that do work like Ctrl + Alt + U does open the User Prefs. Alt + A does play the animation and Shift + LeftArrow rewinds the animation to the start. but the single key hot keys still walk through 0-9…Ugh…I really appreciate all of the insight that you have all handed out. I hope there is something that can be gleaned from the steps we have gone through and the errors we have crossed off the list of possibilities.

This may or may not be related, but I had question marks in input boxes no matter what I typed.

Then I used the on-screen keyboard and found that the default language automatically shifts to Hindi for some reason (everything was in Hindi on the on-screen keyboard).

So my guess is, if you use the on screen keyboard, and everything there is normal, but the problem remains even using the on-screen keyboard for input, you can be sure that windows isn’t the cause of the problem, unlike in my case.

Also, try using the zip available on Blender.org, which works without installation, to see if the problem stays.

EDIT: Another thing, you can also go to User preferences>Input and try to change the shortcut of something. When it asks you to “Press a key”, it will be interesting to see if Blender interprets it correctly.

When using the on-screen keyboard the shortcuts work. When I try and change the blender shortcut keys in the user prefs it also “walks” through the numbers.

One thing that I just found out is; I downloaded an old DOS based video game and when I went to save the game it did the same thing there! I don’t know if that helps also. But it shows that DOS based programs are having similar problems.

It has to be a windows probblem then.
I don’t think microsoft provides support for XP anymore, so I guess you can get better answers over at microsoft forums: http://answers.microsoft.com/en-us. From my experience, you usually get microsoft employees and certified *&%#$ people posting there.

Well I’ve posted the problem there. I’ll let everyone know when they get back to me on it.