Why clipping in Mirror modifier doesn't work?

I don’t want vertices to appear in place where two parts (original and mirrored object) connect, so I selected Clipping mark in Mirror modifier, which does nothing (even after I click Apply), there still vertices at the center. Scale of object is 1.

Because that’s not what clipping option does. Read the tooltip when hover over it. Well you can dissolve this edge and use bisect option in the mirror modifier but when you apply it will be created again.