Why Cycles renders some faces black?

I have imported a model as obj. from rhino to blender. When i use the Cycles render, some faces are black no matter which material i choose. I have already tried to flip the normals but that didnt work. I also tried to delete a face when in edit mode and replace it with an extruded edge but that doesnt fix the prblem either. I can only delete the faces and replace them with planes in obj mode. Here are some pictures of the problem.

  1. I don’t know the answer, sorry, but I’ll brainstorm a few things and maybe one might give you an idea.

  2. It could be related to vertices and not faces by themselves. Is there a setting to assign materials to vertices instead of faces?

  3. Try assigning a new material to only that face.

  4. it could be something to do with obj import/export. Is there a way to make the mesh adopt properties of Blender environment (join to native blender mesh)

I like your work btw. I’ve been using blender for… (omfg) a decade now and i can’t do that. So don’t lose hope just yet. :slight_smile:

1 Like

well as time passed i didnt figure out what went wrong but i am pretty sure it had to do with rhino and not blender. i didnt investigate further as i didnt care about this project very much. but thank you for the reply and stay creative <3

It has got to do with the exporting software, as normals might be percieved differently. Recalculating normals doesn’t work in this case when some of the faces are black.

To fix the normals, select your object with black faces. Go into edit mode. Press Alt + N to open the Normals menu, and select ‘Set from Faces’.

Hope this helps.

it was months ago that i finished this project but i just saw your response. Flipping the normals didnt work but it is in the past now :slight_smile:

I want to reply to this thread since it was the first google result handling that exact issue.
My problematic object was also an import from another software via obj.
‘Set from Faces’ didn’t really work for me, but selecting the complete mesh and chose “mesh/normals/split” did it.

I don’t know why though.