Why do i have those Triangles? (cycles)

to the right is the rendered result, to the left is how its seen in the display viewport

Looks like Z-Fighting. Try moving some of your geometry a very small distance vertically so it isn’t all in the same plane. If that’s already so, you might try going into your cameras settings and increase the near clip distance (lens → clip start) if it is very low.

1 Like