Why do my physics blocks quiver or shake?

I have always noticed that when stacking physics blocks and hitting ‘p’, the stack of blocks might quiver or shake a little bit. I have tried searching around to see if anyone else has mentioned this before but I haven’t located anything yet.

Mind you, sometimes blocks don’t shake. It is hard to nail down why it does this sometimes and sometimes not.

To reproduce quickly:

  1. Ctrl-X to go back to default.
  2. Num 1 for front view
  3. Duplicate cube and move exactly on top of other cube
  4. Go to F4 Logic and set: Rigid Body, Actor, Bounds: Box
  5. Select bottom cube.
  6. Object (F7), Physics button, Fields Collision Tab, Click Collision button
  7. Press ‘p’ to start.

The top cube shakes nervously. Can anyone tell me why and how to stop it? Like I said before, I have managed to place stacks of blocks on top of other collision objects and the shape of the object (perhaps with some extra corners) give all kinds of different results. Sometimes the quiver sometimes not.

Many thanks,
Wayne

It appears I should be making the lower block a static actor, and not to use physics collisions.

Actually I take that back. I dug out my previous test and I already did set my “flooring” object as a static actor. Please see the attached blend file.

There are two identically shaped floor objects. There is no difference in shape. The blocks on the left are duplicates of the ones on the right and are Rigid Body actors.

The only difference that I can find between at all are in the floor objects. One was originally made from a Plane and one was made from a Cube. That’s all.

When you press ‘p’ the blocks on the left will scatter momentarily, whereas the ones on the right will stay stable.

Would anyone be able to shed any light on this weird situation?

Attachments

wall.blend (161 KB)

Has anyone got any ideas on this one? I realise it is a tricky puzzle. I can’t see why there is a difference between the two in the wall.blend file. I’d be grateful for anyone’s insight.

I don’t really know (I’m at another computer and can’t open the blend file on it.). But a random guess is the bounds are intersecting.

lift the top box slightly above the bottom, or try setting bounds as convex

Do you mean the container on the left? Tried lifting that up, tried lifting the actual left blocks up but they have the same pattern of movement before settling.

Also tried setting to to a convex and the block exploded out of the container. There should be no difference between the container on the left and the one on the right. Blocks on the left are an exact copy of the right. It doesn’t seem to make any sense at this point.

With no answer to this strange effect, I have simplified the blender file to show the mystery very clearly. Would someone please download this .blend and tell me why:

  1. Pushing ‘P’ while the blocks on the first plane, they jiggle.
  2. Pressing G and moving the blocks along the X axis to the next plane and pressing ‘P’ again, they do not jiggle.

I know I keep banging on about this issue, and the reason being, I would hate to get into modelling something complicated and find I would have to model it all over again.

Anyone who can successfully stop the blocks from jiggling on the bad plane will receive the title of: ‘THE Blender modeller of the Known Universe’.

Attachments

wall.blend (162 KB)