why does mirring adds black rectangles to my model?


i’m guessing it has something to do with normasl, but all i did was extrude a cube a few times, and add a mirror modifer, then right away i see it has some rectangle on it.

ok, i got it the mirroed half was INSIDE the original model, questions is, how do i make it mirror changes for a sepcific point, i have modelled the object changes to the right side should be applied to the left from the point on…

some thing like what happens during sculpt mode

How many axises are being mirrored? You might have both the X and Y mirrors turned on. Also, did you delete the half of the object that you were mirroring?

There are two or three things which will cause black face issues…

  • Normal mapping, usually fixed by recalculating normals.
  • Sandwiched faces (two faces in the same place), usually fixed by removing vertex doubles.
  • Smoothing on angles around a bend of over 90 degrees, or where there are edges too close together. Check for this by removing any subdiv modifiers and setting all edges as hard (non smooth).
  • Really really bad geometry (e.g. where faces twist in edgeflow so that they reconnect to areas but inside out) can make normals absolutely impossible to recalc.

Those ones are a few quickie possibilities. You got a screenshot or a blend file to give more clues?

lit was x axis, ike i said, i didn’t remove half of the object, how can i do that?

In Edit mode, select the faces on one side and hit Delete …

If you mirrored after the fact rather than interactively; not only will you have to recalculate normals, but also remove doubles.