Why does my object have the same material in texture paint mode?

I have an object with two separate materials, with the white material being unwrapped and assigned, just as the red material. However, in texture paint mode, my entire object is red, and I’m not able to pain on the white image, even with it open in the uv image editor. Here are some screenshots.


Textured view will display the image texture applied to the color value.

My red material looks like this, and the white material is identical, with a different colour.

In textured view, they’re both white, as no textures are assigned. I dont know why yours display as red, and i have to look into the blend file to draw a conclusion, as texturing is not my strongest side.

However, if i add a red texture like this:

i get this result in textured view:

After unwrapping it, i get this:

Now that i do have a texture applied to the model, i can locate it in the UV editor, and edit it there as i please:

Now, in texture paint mode, i can draw freely as much as i please. I cannot paint on the white part, because no texture has been assigned, only a material.

A texture, and a material are very different. A material can use textures, but a material on its own is not a texture.

Need followup, i’ll explain in a bit more detail.

I’ve tried setting things up correctly, but im still unable to paint.
I’ve done the simple steps in a new blend file, adding a cube, applying the texture, uvunwrapped it, entered texture paint mode and off you go.

Following the same steps in his blend file leads to the model being solid white when entering texture paint mode, regardless of what texture, or material is selected. The OP seems to have generated the textures in blender, and failed to export them in order to save them. However, when importing a new texture, it still wont work.

Texturing isnt my strongest side, could someone with more experience look into it? I think he somehow locked it somewhere.

Well, there are several gotchas in that file mostly related to missing data however not only.

First, painting is set to use Image painting mode instead of Slots. And as image RedMaterial can’t be loaded for some reason there is 0 information to be used.

Then, e.g. if Slots is set instead and image is added to material nodes, texture paint is set to Multiply and color is set to black which won’t give any effect on black image (e.g. created by default). Better to set it to Mix mode for testing.

Thirdly, texture painting mask is used in texture options > Texture slot. And as image can’t be loaded 0 information comes through that mask.

Fourthly, some parts of mesh aren’t unwrapped properly like back of the shoe assigned to material ShoeBack selected in the file. Hence paint will fill in the area in one go as all mesh is collapsed in one vertex on UV map.

Lastly note that UVs on the UV map are overlapping. This won’t prevent from painting of course but it might appear unexpected. If painting on different images it’s ok, if on one same area will be used for several meshes which will lead to several areas painted at once.

1 Like

To answer both of you, I actually just changed the painting mode to material and it worked!
Thank you both for your advice! :smiley: