Why does my viewport and render for these clouds look so different?

As the title says - im having troubles understanding why my clouds are less vibrant and full than the viewport

Using eevee


File: https://pasteall.org/blend/80680249e6e8461c9d728e9c17c7abcf

I was having the same result as you, till i turned off transparent background, and then set the background color to black (didnt have your hdri). Volumetrics dont handle transparent backgrounds great I suppose, but it is odd that its fine in the viewport. I’ve found many things tend to be inconsistent between Eevee viewport and Eevee render. It’s frustrating sometimes.

ah man!

Thanks for looking into it - if i cant figure another way i guess ill go for the non-transparent version

If you need the transparency for compositing, you should be able to get the same result by setting the layer to screen.

Yeah thats what i was gonna do, in photoshop - can i do it in here?

Yessir! either in the Compositor, with a mix node, or in the video editor, by changing the blend type.

thanks man - i wasn’t able to make it work in compositor and my view is different to yours on the video editor (using blender 2.9)

this was going to end up in photoshop anyway so i was able to achieve the screen there

thanks for the work around :+1:t5:

1 Like

Happy to help, I’m also on blender 2.9, but I switched the video display to the compositor over there, so I could show both of them in one screenshot. I recently got a new computer with windows, which is far more tedious when it comes to taking, and uploading screenshots, but I should probably just do separate ones without changing the UI like that in the future.

Anyways, glad things worked out! We’re all here if ya need us!