Why is my animation not rendering with sound?

No_Audio_Out.blend (725.4 KB)

After reading some posts saying that just using the wrong Frame rate could mess up the audio, I rendered the movie with 4 different frame rates, to no avail.
I have tried different combinations of File Formats, encoding containers, and video codecs, also to no avail.
Unfortunately I need 2 things in the final file: Alpha transparency, and sound.

if you know what is the “exact” combination of File Format, encoding container, and video codec I need that would be great.
Unless you want to inspect the attached file and take it from there…

These are the Rendering specs:
File Format: FFmpeg
Encoding Container: Quicktime
Video Codec: QT rle
Audio Codec: MP3
Frame rate: 24fps

Thank you in advance guys!


Hello -
At first, I tested your settings, and they worked for me. I then tried opening your file. I believe this is a pre-2.8 version file, but when I open it in 2.79 Blender immediately crashes. I can open it in 2.82, but who knows if everything translates well. In any even, I noticed that in the Scene:Post Processing tab, you do not have the Sequencer enabled. I tried to test, but again, Blender immediately crashed when I attempted to render.

Mmm, that’s interesting. Thanks a bunch for trying Phil :slight_smile:

I just recalled using the Speed Control Effect modifier in the Video Editor in the past. It was like a requirement. I’ll try that.

Nope! Not even using the Speed Control Effect Mod helped :frowning:
I also checked Sequencer. While it was on its 2nd or 3rd second rendering, it crashed.
I am resorting to delegate adding the audio task to a video editor app (Shotcut). But it would be nice to have this resolved.
Maybe I’ll try appending as much as I can from this file to a new one and hope it’ll work.

Hey there - I should have mentioned that prior to 2.8 I would use a stand alone version of ffmpeg in order to combine a RAW AVI output from Blender with an audio file. The 2.8 version works much better with audio, but still has syncing issues I have noticed. Good luck!

Thank you Phil :slight_smile: