Why is my PC slow while rendering??

Im using GPU cuda to render but my whole PC slows down while in render view mode. I thought the GPU would handle everything and leave the CPU out of it… in fact the CPU is only using 20% (AMD Quad core 3.4 Ghz) but everything like internet browsing and just clicking windows is slow.

Surely is not your whole system becoming slow, only what has to do with the video, as when you try to switch between windows of different applications or in web browser. That’s why some people use two video cards. The less powerful card for the system and the most powerful card for rendering. I really do not know if the problem you describe is still happening with modern cards.

Ill have to do some investigating to see if the whole system is slow or just the video part. From what I heard windows UI doesnt use cuda so it should have no problems

Just checked, used my onboard video to browse the internet on one monitor and used the GTX 760 to render on the other usng GPU compute and everything was running slow

Did you figure it out?
I’m also having the same problem. I changed one element in the render for the same file and the same view, samples from 500 to 2000, and the rendering time changed from 9 minutes to 20 hours with two GTX 980. I’m still new in using Blender in PC environment and it seems like everything needs to be tweaked.

You don’t possibly have square samples ticked do you?


If so, it means the samples being rendered is a squared value, so 500 = 250,000 samples, while 2000 is 4,000,000.

The ‘environment’ your using Blender in isn’t going to change how you set it up :slight_smile:

No, I don’t have the square samples ticked.
I should’ve said I’ve never had a computer that I can use the GPU render so it’s totally a new thing to me. My old macbook couldn’t handle the GPU rendering and I’d just get a black screen. There must be other settings I did wrong.

I think it is not, you are describing a different problem to the issue posed by “jcrew3002”.
Anyway, I think your problem may be related to what “zeealpal” said.

YAFU, the render time is just the other observation on top of the ones I had with the slow responding of everything else during the rendering. The render was almost done when I saw this post today, so I switched the computing from 2 GPUs to just one and the speed of responding from Chrome and other general clicks improved but still lagging. So I am going to try what you mentioned about having the onboard graphic handling the normal display and have the two 980 completely for render if possible.

This is probably because you use the same GPU for rendering and display. When the GPU renders, it’s probably at 99/100%, so there’s not much memory left for basic display stuff…