Why jumps the Ragdoll if it walks a step up?

Hi all,

since a few weeks, I try to write further functions, by example handle steps.
Now I don’t come further:
After a rewrite of a function, the whole ragdoll jumps a little bit up and back, if it stretches out the left hoof. This is not intentional, the strtech of the leg is only for lift the whole character up enough that it can walk over the step. It’s the function stepUpLeft().

The file I attach here: Minotaur_steep_terrain_ dev_overwork200.blend.zip (2.68 MB)

Best regards,

I have forgot to write that I try to write better comments and more of it.


after no one answered, I tested some parts of the old code in the rewrite of the function an it worked. But now I have an other problem:

I wrote the function to end, it worked fine. Now I wrote a mirror of the function for the right side, although the stepUpRight()-function is a name-mirrored copy of stepUpleft() it don’t want to be called. I don’t know why not.:confused:

Under the following link the new file can de found:https://www.dropbox.com/s/tgn4h2tl69c0kh3/Minotaur_steep_terrain_%20dev_overwork300.blend.zip?dl=0

Best regards,

Hi all,
after some test, I figured out that the number of functions in GE-Python under Blender is limited. After I have merged the stepUp-functions to one and commented out two dummy-functions. It worked again, so I could look for scripting fails for the right side. There was some of them.
How ever I post the link to the file now: https://www.dropbox.com/s/dexkvkfmpa4u29v/Minotaur_steep_terrain_%20dev_overwork348.blend.zip?dl=0

Best regards, Arne.

Hi Arne,

I have a similar problem. I checked your last file and it sort of explodes when running. Does it really work?