Why so slow!

I dont know why but I added some lines to my script and suddenly my game became really slow.

Cross Heir.blend (152 KB)

Runs at 60 fps on mine, although you forgot to pack the textures.

I made a few changes to your script though. It now follows the cursor in real time. Cool idea btw.


Cross Heir.blend (152 KB)

what did you change? I didn’t see any difference. Although it did run faster for some reason. I think it might be because im running it off of a memory stick right now. I will try it off my hard drive.

I meant logic bricks. I turned on true lvl trig on the Always sensor, so it will update, and I turned on tap on the click sensor, so you can add more than one each click.

Do you think I could use part of this for my game?

Oh yea sure. I just made it for fun. Go ahead. Would you like me to send you the packed version?? It looks way better.

Im pretty sure that this is the packed one.
Cross Heir.blend (152 KB)

Unfortunately, that wasn’t packed :stuck_out_tongue: But no problemo, I only needed the code.

haha… Really? I thought I packed it…I think im going crazy…Oh well. xD

Have you checked your video card? I once had the same problem that my computer lagged very much when i added textures. I don’t know why but blender textures take soo much from your video card while with all other games my computer worked perfect.

I am new to the BGE, but something that “got me” recently was that I had the display debug option enabled. That is great for debugging, but it really takes a hit on the frame rate, especially when you have several properties set for debug.

You can use a program like FRAPS to show the FPS on top of any 3D application. That doesn’t affect the framerate at all. The demo version will only let you record for a limited time, but it’ll let you see the FPS as much as you’d like.