Why the image became ugly at a plane?

Here is a face I will put in my game(it´s from a dark elf).why the original image at right became so terrible when applyed to a plane(left)?


It’s antialiased. Switch it off in the image texture tab. Mipmap does something similar.

Here is a blend with the image.I think it´s not antialiased or mipmaped still…can you fix it?

that is just the (UV mapping) OpenGL preview, it does look different in final render. The preview is … somewhat limited.
In your file you didn’t even set the image as texture. If you do so, then you can unset the button “Interpol” (not Antialias, as I wrote before) and you will get a your original image quality.

err…final render? I will use it in a game. I found the options you talked about,but it doesn´t worked when I turned on game mode. It only worked for renders.

O…h. Yes, you wrote “game” there. I am sorry. I don’t know how to turn off the interpolation there, guess it’s an OpenGL thing. Maybe you could ask in the appropriate Game Engine forum.

Going to ask,thanks for helping :wink:

There is nothing you can do directly in blender to get rid of this ‘blurring’ It is caused by magnification that is applied to all texture by OpenGL.

However, with a simple python script, it is possible to turn off texture-magnification (and texture minification) by an OGL API call.