Wild fluid movement?

Hi guys,
Fluid sim newb here so hopefully this is an easy one:

My goal is to have a product shot rising out of water, but whenever I move a collision object within the fluid, the surface goes wild.
I’ve tried to boil it right down to a simple scene of Cube in water but still having the same issue.

Increasing the divisions makes little difference (rendered below at 64, have tried right up to 256)
Scale is applied.
Origin set to geometry (prior to bake).
I’ve tried adding substeps to object and fluid - no joy.

Here’s videos of the render + viewport so you can see what’s going on.

As you can see, the fluid behaves as expected until shortly after the cube moves.

Any help or ideas would be amazing.

2.93.3 file:
Cube Dip.blend (899.1 KB)


Hmm after reconnecting you sky texture … looks fine to me (did you clear your cache??)

Edit: Ups sorry i was distracted, i did play arround some time because of the pink/no texture and changed the domains Physics Properties → Fluid → Settings → Resolution Divisions to 32

The drop in divisions makes it look less of an issue. You can see the fluid sort of buckling around 45 frames in. That’s the point it goes crazy at higher divisions?

P.s. Sorry, using an add on for the Environment!