windows 32 bits problems

i got windows 32 bits with vista

and i can run SVN 53922
but i tried this week other SVN after up to 55089

and i can see the console window come up then the main window and it crashes
and no error window telling what the problem is!

so does anyone else has experience crashes like that ?

thanks for any feedback

you got your revision numbers wrong.

I just downloaded r54099 on the buildbot to see how it does on my XP 32 bits and it works without problem.

To test if it’s some settings conflict , add a config folder in your …\blender-2.65-r54099-win32\2.65
so you obtain

And put your \blender-2.65-r54099-win32\ directly in your C:\ (or D:\ or whatever letter is your main hard drive) so you have
To avoid some problem with how vista manage folders in the “program files”

And launch Blender again to see if it still crashes on your system

was there any changes done to th installation ?
i mean i did 100’s of SVN since last year and it has always work fine
except this week
i treid to start the exe from the folder where it is lcoated and it is refusing to start normaly

i’ll do a test righ not ot see if i add a config folder locally and see if this works


ok just did a test

added a config locally in SVN folder and it still crashes

remove that config folder
went to the app folder common installation for blender
remove the 2.65 config

and now seem at least to start up but dont’ have the startup file i’m use too!

ok so this seems to have something to do with the start up file in lastest sVN

but when i re started it
it crashes now with an error message

at least it’s beginning to get it working

got some bad news today from bug report

seems these old cards are not supported anymore


You should mention on the bug tracker that you made it work by removing the 2.65 config, because if it worked , then the problem is not your card (or it would have never worked)

i just did and waiting to see answer
but did not really like that they are supporting these cards anymore


get a new PC or Vid card
and i have a small PC & small power supply so cannnot add a big video card to replace old G31-G33

so may have to wait a little for a good sale and get a new PC!


can you give some tips on how why yours seet up is working may b e

i remove the start up file from the app folder
and today i got the 54108 SVN and still having crash on start

do you have areo set up on it ?

Note: i may have to get a new PC but that may take while and meanwhile hope it can work


I’m on XP , not on Vista, so where i put my Blender directory does not create problem like it does in Vista that have a very different policy regarding it.
But if you have that vista aero thing, disable it, i often read it create lots of problems with several applications.

Additionally i had to change my motherboard last year due to the old one being sadly fried, and on the “new” one i have a G41 instead of the old G31/G33 of old ( G41 support OpenGL 2.1, and so GLSL, while G31/33 can only support OpenGL 1.4), so i don’t have the same setup as you anymore.

On every of my Blender directories (i never use the official installers, i always use the zipped one) i have the “config” folder, so none of my settings and startup blends are saved in appdata/user shared location (that i suspect may be linked to your problem too, as i remember you very bizarre problems with scripts and plugins of various versions that were completely mixed up) .

All i can suggest for you to try is this :

  • download the very latest Blender on the buildbot
    at the time i write this, it is

  • extract the folder named blender-2.65-r54108-win32 from this archive

  • put that in your C:\ (or whatever is your hardrive letter) so you obtain

  • create a folder and name it exactly " config " ( without the " " of course) in
    so you obtain

  • go to your C:\Users\ directory (as i have read Vista put the appdata files there) and look in the folders and subfolders there for -every- trace of what blender would have left (.blend or .txt file)
    delete them all to be sure none of them is responsible of what you’re currently experiencing.
    Do not empty the trashcan, so you can get the files back to where they were in case this does not improve your situation.

  • Now go to C:\blender-2.65-r54108-win32\

  • double click on blender.exe

Is it working now ?

tried with blender in C root
and remove all fodlers from app folder

still crashing on start

anyway i’ll watch for a new PC
with probably a much faster video card but could be a radeons to start with
hope that one can work with blender and have GLSL work properly this time !

i heatd sometimes Vista gave some problems to some peoples
but i must say that i never had any problems with my vista instalation!

just check bug report
and seems that other peoples too have crash on start problem

thanks man

I noticed the one reporting the bug has a nvidia, so it looks like it has nothing to do with your card.
Just to test, try this :

Download the attached file , in it there’s “startup.blend” and “userpref.blend”
Put both blend files in your


(of course delete anything that could be here first)

The difference with the default factory is that i have gone in File -> User Preferences -> System and disabled “GPU Mipmap Generation”, turned OFF the Anisotropic Filtering and disabled “Text Antialiasing” , then just for testing in the i removed the shading from the buttons in User Preferences -> Themes -> 3DView.

Those settings turned off may improve a little bit performance, but more importantly, they should then be easier on your G31/G33 , so if the problem is with the G31/G33 , maybe this will help.

Attachments (107 KB)

don’t see that userpref blender file
in which folder does this goes ?


my 53922 is working fine
it’s looks to me that the problem starts with the new serie 54…
so not certain what they did to it!


re-read my post, it explains where both files (that are in the will go.

did test with 2 files in new C root folder for blend
and i do get another window opening pronably the user preference one
but then it crashes again

hope dev can look at it and find what happen in 54 serie may be!


another window ?
Very strange, there should not be another window , all there should be is :
-the DOS prompt at launch
-the splash screen
no other window, the user preference window should not launch with those startup blends.

i did remove the old config from app folder
so not certain why i see new window probably the new userpref file may be!
which i don’t have anywhere else !

was there any new features added in 54 serie ?
may be something using some opengl 2 instead of opengl 1.4
how about these new viewport alpha settings
are they set on by default in 54 serie?

how aobut this new matcap thing
is it set in 54 serie?

that might be enought to crash it

but which new features is doing this ?


I have no idea what is the new alpha you’re mentionning.
For the matcap, they’re in current builds, but they’re not enabled by default so they shouldn’t be a problem.

Additionally, i have not noticed anything working or looking different in recent builds, there’s the gradient background, but again it is not enabled by default so it shouldn’t be a problem.
There was the Region Overlap , though it’s +/- a month old already, but it needs you to set the “Window Draw method” in User Preferences -> System to “Triple Buffering”, because by default it is set to “Automatic” and region overlap only works in Triple Buffering.
So it shouldn’t be a problem.

There’s the rigid body from the bullet thing that was very recently integrated , maybe it plays a role as it is enabled by default as i see the entry on the toolshelf ?

I really don’t understand why recent revisions are crashing for you and some other people too, Blender does not look any different on my system than it was a week or two ago on my XP 32bits

by new alpha = gradient background

i think i already set the region or viewport ovelap which is working in 53922 and i use it so not a problem
this rigid body might be one possibility or this new matcap!

will have to wait i guess and see what devs comes up with
or until i get a new PC

but hope they can find it soon !



On top of desktop Linux box, I have quite old Toshiba laptop at times, with winXP 32bit, Intel video, 2Gb RAM on it. It never did support OpenGL GLSL part in blender despite latest Intel video drivers and what not. Some short time after 3dview background gradient was introduced on buildbot (i download blender all the time from it, have settings in separate /config, last file working r53940), i started to get crashes with message “Memory at [some address] could not be read” while opening User Preferences window. Helped opening User Prefs in some main window corner, not in separate window. Two latest builds i downloaded, ended in the same error message upon blender start. I got PM from Ricky asking about crashes at the same time. Could be r54002 when it started crash.
There is text file crash.txt being created with no relevant info in it.
I started blender from terminal with --debug-all switch - that led to some normal behavior messages; then crash.
I could add more details later, if needed, but so far it looks like some older hardware might prevent blender from start on win32 builds.

Edit: This is what happens on v54061. The same goes for r54134. Toshiba TECRA A8, Mobile Intel 945 Express cs Family.

did you add it to bug report
might help dev to find bug !

i can see this tmp text file and it is empty too