Windows10 vs Linux Mint - render quality worse on Mint - any ideas?

Hello all,

I’ve seen loads of threads on how Linux can render images more quickly, and I always presumed they’d look the same, but mine don’t - in fact the same file on Mint looks awful!

I have an i7 cpu and nvidia gtx 980 gpu. Windows 10 pro and the latest Linux Mint. All up to date.

On both I have release candidate 2 of Blender. And using Blender Cloud sync all my settings are the same.

In Mint I ran the drivers app and selected the Intel and Nvidia Drivers.

I have a work in progress file created in Windows, I packed all images and saved to a USB stick. I then re-opened Blender and hit Render… and saved the image as a PNG.

I then booted to Mint, opened Blender, opened the file and hit Render, and saved once more.

As it was rendering I could see the quality was much worse in Mint.

Both files are linked below, and tagged with the OS they were rendered in. Mint was quicker, but the file size is bigger, and it looks poor.!AmSBACT5SF1xg_VhHaRE9CxVzT9Jgg

Any ideas anyone?! I’d love to get it working properly.



There should be no difference in the outputs.
But: looking at your renders, the second is done with a way lower filter setting in any.
Why this is i cannot say atm., but check the film->filter type and width pls. Perhaps that
got lost somehow if your blend was older and did not store the newer options, thus had a
unwanted fallback.


And just like 99% of everyone else, you didn’t include the most important file, an example .blend users can test on their systems and check the settings. Release candidate is a candidate in case users find problems that need fixing before the release.

Some observations. The Mint version is aliased, Windows version is anti-aliased. If it was rendered in Cycles, those depend on the samples to get sorted out so something is screwy. It’s also interesting how uniformly non-uniform everything looks, except where one would expect those to be the worst like shadow areas (cast shadows on the side, and holes in the foreground). Noise should be greater because it depends more on indirect light, not almost invisible so that it has to be multiplied by 10 to get the differences showing.

It’s funny you mention that because I uploaded the .blend a few minutes ago! It’s in the same place as the images.

I’ve noted the film settings etc… and will now reboot into Mint to see if there are any differences.

Thanks for the input so far.

Thanks for your help guys - with 2.77a - with default settings, and with my new 2.8rc2 settings - it renders exactly the same as the Windows render. Although Win10 renders 30 seconds quicker than Mint - leading me to think I should just stick with windows!

I’ll try to report it as an RC2 bug.

Many thanks again.


p.s. latest 2.77a render has been uploaded for completeness.