Wireframe display issue

Hello, Everyone!

When wireframe is turned ON in display settings only a part of the mesh is shown. It would be awesome if the whole mesh would be shown. I really hope that there is a simple way of dealing with this issue as it seems quite minor.

Happy blending!

There is, near the wireframe setting in the geometry tab there is a box that says show all wires.

You, Sir, deserve a high five! Thank you :slight_smile: