Wolverine in Classic Brown Costume

Here is a Wolverine model I’ve been working on lately. I’m still new, so there is many things I’m still learning. First time sculpting and making a normals map.


One problem I’m having is the normals map. It seems to have this weird “line texture”. Even if I don’t sculpt something and just make a normals map, it still has a weird look. I bake at level 5. If I take the normals map off, the lines go away. So it’s 100% from the map.


Maybe they are generated from an flat shaded mesh?

have you turned on the no color data option on your normal map?

I know that there is one in internal, but have no idea for cycles. It works ok in internal. Just click the normals option under textures/image sampling and it looks good. But I don’t know of that option in cycles. But I can tell that is the problem.

Can you show us your normal map? the file itself… That may help to see the causes of that…

But I’m pretty sure it’s an option I’m not doing. Because when I add the map to internal it looks really bad. I click on “normal” under image sampling and it smooths it out. But there is no normal box for sampling under textures tab with cycles.


Yes, your Normal map seems pretty “normal”.
Just a note, you have some strange resolution in some parts of your map, as if it was really low def in the arms or legs for instance, and more precise in other, like the torso…

I agree with SheepHP, it looks like you didn’t choose the non color data option in the texture node of your normal map. Have you done that??

I’m not sure where that option is in cycles.

there ya go

Oh sorry, I know of that one. I was thinking it was some option somewhere else. That one I already have selected and it still causing my problem.

Maybe I don’t have the right option on my normals node.


Why are you connecting a normal map to a displacement socket? Displacement sockets are for inputting a single value, to act as the height of a bump map.
I think you’d get better results from connecting that normal map to the normal input socket of the diffuse shader. You know, normal->normal.

Haha this whole I didn’t notice I had it connected there. I somewhere kept ignoring that. Thanks

Send us a view of your character now with the right nodes connections to see how it looks now!! :slight_smile:

Sure, no problem.


Now that’s 100 times better.