Workbench render shadow issue

Hi guys,
I want to use the Workbench renderer with a nice matcap. It looks great, the only problem is when I press Ctrl+F12 and get the render (I’m saving to OpenEXR but the problem is repeatable on any output format) I have shadows flicker on and off as the camera zooms out. (I tried dollying the camera up and away and I tried animating the Focal Length, either way I get the issue).
I will attach 2 frames, where you can see the shadow is not happening and then is happening.

I tried on the latest 2.81 and on a little bit older 2.82 build. I also tried updating my Nvidia drivers.
Thanks in advance for any help

EDIT: The shadow I’m talking about is on the left side under one of those leaves. It suddenly appears on that particular frame. Also I’ll upload a screenshot of my Workbench settings:

The issue only happens when I render. It does NOT happen in the actual viewport.