Working Fine, Crashed, Won't Open

The title explains it pretty well. I was working on a mech and while I was working on it, it completely crashed. Whenever I try to open it (or append it), Blender instantly crashes. I’ve tried appending separate objects and none open, and a selective few crash.
I don’t know what else I can do for it. Is it corrupt and unfixable? :eek:

I’n a couple of cases, I’ve been able to rescue the contents of a file by appending the scene(s) from the damaged file in to a new .blend file. Have you tried that?

Eta: Sorry. I see you have tried my suggestion…

Masteraar, may it is possible to upload the file for eg here:
The file is maybe corrupt but should not crash blender.
You could try to open blender in a command shell with blender -d and open your file to get more info.

Cheers, mib.

EDIT (Again):
Here’s the file as requested, and I’ll try and do as you suggested.
Thanks for the help, mib.

Opened your file in blender 2.62 and it crashed
Opened your file in blender 2.63a and opened ok
Resaved the file and it opened in 2.62

Thank you so much, Richard! Words cannot express my gratitude.
It must have just been something with 2.62, I guess (mainly using it for Octane Render, since I don’t believe it’s compatible with 2.63 yet).

Thanks again, Richard and Mib!