Working with linked datablocks

Is there anybody who has experience with linked datablocks in serious projects?

Now I working with game levels (Boom and a car racing game levels) and I use Blender’s link option… There is some strange things… For example, with Apricot builds I cant link from a .blend that I already linked something (I have send this bug in the bugtracker.)

But now I have new problems. Sometimes when I add materials to a mesh, in the blend where I linked it, the mesh has only one material.

  1. I have a mesh with one material
  2. I use this mesh with link in my game level .blend.
  3. I have edit this mesh and I have add a new material to it, so this mesh now has two materials.
  4. I load the game level .blend and this mesh has only one material. (It is linked, not appended!)

So, what can I do?

Could you give a tracker number for others to check the bug cause I have a similar issue with linked stuff.

Hm I cant find that bugreport…

endi, you should be able to find it easily through your “My Page” when you’re logged in at - if you can’t see it there, then it is most likely fixed and closed. In that case you should’ve received mail messages telling you that the status of the report was changed.


New link bug: if I have a mesh that is linked, I can not modify its modifiers… Strange.
(Posted in bugtracker.)

Very sad that unable to work with linking… :frowning: Bugs and bugs and bugs… :frowning:
Is anybody uses this function? (For serious project of course. Please dont write if you try this function only one time and you say “it works for me”.)

modifiers have nothing to do with linked meshes, they are attached to the object, is not mesh data (like UVs or vcolor or shapekeys).

Try to explain more about the stuff not working for you, the linking system in Blender is very powerful and I use it all the time, no big deals, worked great in both small and big projects, I even include it in the Blender Essential workshops :slight_smile:

I was having trouble with linking a proxy while at the Blender conference, and Ton tried to help me…but couldn’t. [using 248.1] He said I should ask Bassam to try and find out ’ what I was doing wrong '. I was just try to link a proxy as explained in FAQ and had done previously without problems. After maybe 2 hours of trying various ways of grouping, updating, closing & re-opening Blender I could only conclude that there is inconsistency in the data Blender attaches. When Bassam found time to speak to me he said enough - yes the linking system is a bit buggy. Does that help…

I’m currently working with linked groups and am trying to composit using ID masks - doesn’t work either… :frowning:

Now I have a big problem. I have a rig and many blends that links this rig.
I have modified the rig and the when I load the blends, Blender crashes… :frowning:
This is a very big problem…

Did you report it to the tracker?

This not help me now… I use 2.9. As I know bugtracker only for 2.5…

I’m pretty sure they will fix “showstoppers” in 2.49, it’s worth a shot anyways incase they release a 2.49c version.

This look like a very elementary problem: I renamed a bone… I dont think this is easy to fix…
Sad… very sad…
I like to use Blender for a serious project… I hope I can.

I tried using it for a complex animation and it didn’t work out very well at all. It doesn’t play very nice when it needs exporting to external render engines and weird things happen quite a lot. I had a fully rigged and set-up subway train animated for the final scene, yet after saving the scene it refused to move, I couldn’t delete anything from the scene.

Maybe I did something wrong, but I do believe the functions haven’t been properly production tested, totally not the developers faults though, just one of those things. I’m sure it’ll be looked at though, especially for Durian (Probably already has actually for ED and BBB come to think of it)