Wrong filling importing .svg

I’am trying to import a svg file in Blender, but the filling comes up all wrong.

The file comes from a vectorized .jpeg, it looks all good in inkscape, but some parts change filling color once imported in Blender. The work flow works pretty well for other images, but when they become too complex this problem appears. I tried to clean up all small and unnecessary paths in inkscape and combine all remaining paths: same result…

Thanks for any tips !

You could try and save your image from inkscape to a high resolution PNG image… let’s say 8000pixels (height or width, or both if it is square)… then head over to:


upload it there and get it converted (into an SVG)…
…download, and there you go.

just a thought, since it always worked for me without issues.

edit: on a side note… your vector is rather detailed and therefore contains a LOT of data… I think the conversion into SVG (whatever algorithm is uses) may limit the lines of coordinations to whatever canvas size (or document size) you are using in Inkscape… I have no idea about Inkscape but I could imagine that it asks you what the dimensions of your project are at project creation and the SVG converter/exporter keeps a certain ratio in consideration… If that is true, you would need to have a rather huge canvas/document for the amount of detail (shapes/silhouettes) which you have created there. Also, maybe the exporter configuration lets you choose the amount of shapes and it was set too low.

you can try to increase its size in Inkscape before importing, or add the jpg in Blender as a Reference image and header menu > Object > Trace Image to Grease Pencil

Hi Scaulier,

You might want to try Leafig addon ($) by ambi. I use it to generate meshes from alpha’s or images often. Convert your svg to a high res PNG file with alpha channel (if possible) or background as 1 color (or as close as you can). It’s the one addon that works consistently for me. Your file looks like a tricky one though so some experimentation would be needed. I’ve had lots of success with the “Distance” option. Hope things work out.

Here’s a example screenshot of a quick test I did using Leafig.

Rendered output (cycles):

Cheers and stay safe!

Thanks! I tried your online converter, it works pretty well, the resulting SVG are pretty neat and open well in Blender. That’s a good workaround my problem!

Thanks for the tip. I got one more question that I am a bit ashamed to ask: once the addon bought and installed… how do I use it? :face_with_raised_eyebrow:

Never mind, I found out… works pretty well, thanks!

Hi Scaulier,

Glad it helped! Looking forward to seeing how everything turns out!

Cheers and happy blending.