Wrong python path?

I’m trying to compile blender in xubuntu 11.04 x64, but when I run scons, I get the following output:

scons: Reading SConscript files …
Command-line arguments
No command-line arguments given
Command-line targets
No targets given, using default
Using config file: build_files/scons/config/linux-config.py
user-config.py not found, no user overrides
Build with parallel jobs: 1
Build with debug symbols: False

Missing: “/usr/include/python3.2m/Python.h”,
Set ‘BF_PYTHON_INC’ to point to a valid python include path.
Containing Python.h for python version “3.2”

The problem is that the script is looking for python in /usr/include/python3.2m/Python.h,
while python is actually installed in /usr/include/python3.2/Python.h. (notice the missing m in the path name)

Python is installed and works just fine.
I’ve also checked linux-config.py in the source, the affected line is BF_PYTHON_INC = ‘${BF_PYTHON}/include/python${BF_PYTHON_VERSION}${BF_PYTHON_ABI_FLAGS}’, but I fail to see where the problem is.

Thank you for your help,

There are several ways of compiling the ‘abi’ (application binary interface, i think) for Python, and they have different suffixes: ‘m’, ‘mu’, and ‘’ (empty). I forget what the difference is, but I think they all work with Blender, you just need to get it to look for the one you installed. In your case, you have the ‘’ (empty) one installed, so you need to change BF_PYTHON_ABI_FLAGS to ‘’.

Hi, Im having the same problem, with Ubuntu 11.04

My Python 3.2 include directory is in usr/include/python3.2mu… Im getting this error

Missing: "/usr/include/python3.2mu/Python.h",
  Set 'BF_PYTHON_INC' to point to a valid python include path.
  Containing Python.h for python version "3.2"

Also I dont have Python.h anywhere on my PC and I dont know where to get it :confused:

EDIT: can I use the Python.h in blender s lib/python directory (i mean directory with libraries needed to compile blender)
EDIT: Just realised what linux lib has no python subdirectory :confused:

hey i’m sorry to bump this thread, i know it’s like 8 months old, but i ran into the same issue and am wondering if howardt could help me out - i have /usr/include/python3.2 and /usr/include/python3.2mu but i don’t quite understand how to change BF_PYTHON_ABI_FLAGS accordingly. how do i change the value in linux-config.py?

edit: good grief, never mind, i’m a dork. i just needed to use my eyes. my apologies.