x-axis mirror decided to take a vacation

So, I’m modeling a catfish and was using x-axis mirror and all was right in the world. But, for some reason, I tried to use it again and I guess it’s on break because when I do something to one side of the mesh, it doesn’t happen on the other.
I’ve tried rotating it on this axis then the other in pretty much every combination I could think of, but nothing seems to get it working again. I’ve also tried re-centering it and still nothing.
I haven’t used Blender in a while, so it’s possible that I could be missing something, but I just wanted to know if anyone knew of any fixes for this problem.
Please help! :frowning:

You can use the mirror modifier instead.

Thank you for the response.
I actually got that same advice from a friend, but I made the fins from shared edge extrusions, so I’m not sure that that would work correctly for what I’m going for. My main concern is just trying to get the x-axis mirror working again.

I actually got it to work again. (Global/Local coordinate mix-up)
However, now it only mirrors transforms, but not extrusions. I could’ve sworn it mirrored extrusions before though…

X-mirror does not work on any action creating new vertex, like extrusion, loops etc. The best way is using mirror modifier as someone stated before. The mirror Modifier will always work, you can make the model mirror on any axes, also you can control the clipping. If you were using X-mirror then Mirror Modifier will work for you 100 /100. But you need to delete half of your model ( the mirror half ).

Thanks so much guys! Your input really helped out and I will apply your advice. :slight_smile: